ATi drivers installation problem

#1
I have a new problem. Anytime i want to install ATi drivers(i have HD4870), the install program stops working. Does anyone got an idea how could i install the drivers?

Problem:
 


#2
I have a 4870 myself. If you want to use the 8.12 drivers, you need to run the installer in Vista Compatibility mode. I however, use the 8.12 Windows 7 preview package (linked on their drivers page) and it works flawlessly.
It could also be that you already have the driver update (prerelease WDDM 1.1) from Windows update installed. I'm not sure if that would interfere as I installed the update after I installed the 8.12 preview package.
 


#3
Be sure to uninstall every little bit of erlier ATI driver before you do a installation run as admin... ;)
 


#4
Be sure to uninstall every little bit of erlier ATI driver before you do a installation run as admin... ;)
Can i use Driver Cleaner PRO for this?:rolleyes:
 


#6
How much system memory do you have?
 


#7
I have a 4870 myself. If you want to use the 8.12 drivers, you need to run the installer in Vista Compatibility mode. I however, use the 8.12 Windows 7 preview package (linked on their drivers page) and it works flawlessly.
It could also be that you already have the driver update (prerelease WDDM 1.1) from Windows update installed. I'm not sure if that would interfere as I installed the update after I installed the 8.12 preview package.
I've gotta try to install catalyst again.

I installed catalyst 8.12 and it gave me no errors and I had the prerelease WDDM already installed but I removed it and windows didn't tell me to restart so then I installed the 8.12 catalyst. Then I restarted after the catalyst install and when I did the prerelease was back and I see no trace of 8.12 even though I had just installed it without errors.

So where do I go to look at the settings for my video card? I used to right click on my desktop and go to properties advanced...blah blah...

Is that settings menu just nonexistent now?
 


Last edited:
#8
From controlpanel...
 


#9
try this beta version of ati catalyst control center speciale for windows 7
Link : AMD Customer Care
 


#10
I have the same problem as you trying to install the preview drivers. Just stops dead in its tracks. Not sure what driver you are trying but the Vista 8.12 drivers work sweet as for me with a normal install
 


#11
same problem for me. no catalyst driver will install for me, neither vista nor windows 7 driver. installer just stops doing anything after a while.
what DID work was simply uninstall the graphics card in the device manager and reboot - windows 7 took care of installing the Windows7-Edition of the ATI driver then, worked fine for me.
 


#12
I'm having similar problems and when it gets to a certain point, it just freezes.

I'm not sure what the problem is, because I was using the Vista 64bit drivers just fine. I'm a big gamer and this problem is already making me twitchy. LOL. Any input would be appreciated.
 


#13
I'm having similar problems and when it gets to a certain point, it just freezes.

I'm not sure what the problem is, because I was using the Vista 64bit drivers just fine. I'm a big gamer and this problem is already making me twitchy. LOL. Any input would be appreciated.
Same here but then I realised that the Vista drivers work fine on all my games. I don't worry about it anymore:cool:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.