Bitlocker denying write access to usb thumb drive

Discussion in 'Windows 7 Help and Support' started by jaf2000, Mar 21, 2012.

  1. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    RESOLVED!!!!!! :teeth_smile:

    I went to my system restore points and only saw one there from 3/30. That was strange, as it should have been capturing them frequently.

    Anyway, I figured since two of my usb drives showed up as write protected on the windows 7 system and they show up fine on windows XP and windows 2008, I figured it had to be something that changed recently as you suggested. After pouring over the group policy editor (gpedit.msc) and not finding anything enabled, I figured something in the registry must have changed.

    So I hunted in the current control set and found a setting RDVDenyWriteAccess enabled.

    After hunting on the internet, I found this.
    http://www.group-policy.com/ref/policy/2866/Deny_write_access_to_removable_drives_not_protected_by_BitLocker

    These two settings are mentioned on that site.
    HKLM\System\CurrentControlSet\Policies\Microsoft\FVE!RDVDenyWriteAccess
    HKLM\Software\Policies\Microsoft\FVE!RDVDenyCrossOrg

    The RDVDenyWriteAccess was set to 1, but the RDVDenyCrossOrg was set to 0. After disabling RDVDenyWriteAccess, I pulled out my usb drive and re-inserted it. And I could write to it again!!! :teeth_smile:

    I am so relieved. Thanks all for your help and suggestions! It is appreciated!
     
  2. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    Glad that you got that solved. I had a hunch that System Restore would be your last possible option. Always, from now on, make sure that your flash drive (or any external drive) is not plugged in while updating.

    Another thing, while we're here. Do you backup your computer? If not, now's the time to begin to do so. Because sometimes, System Restore doesn't give us the desired results. Some updates wipes all of the restore points out (like SP1 did). I've had it to work for me & had it not to work for me.

    A backup image, taken when everything's in good working order, is the safest bet that you'll have.

    Best of Luck,
    Cat
     
  3. RadhaKrishna Balla

    Joined:
    Jul 16, 2014
    Messages:
    1
    Likes Received:
    0
    Thanks much "jaf2000".
    Your suggestion works like a charm.. thanks for your persistence in finding the solution, it helps others like me.
    u r da man!
     
  4. mkztg

    mkztg New Member

    Joined:
    Apr 23, 2015
    Messages:
    1
    Likes Received:
    0
    I was having the same issue, this solution didn't work for me but I did find one that did. I wanted to share that in case others also ran into the same problem.

    Run the gpedit.msc and navigate to:

    Computer Configuration | Administrative Templates | Windows Components | BitLocker Drive Encryption | Removable Data Drives |

    My system had the setting for "Deny write access to removable drives not protected by BitLocker" set to Enable. Change to disable. That will also stop the system from asking to encrypt the drive every time you plug it in too.

    Hopefully this helps someone.

    -mkztg
     
  5. YashS

    YashS New Member

    Joined:
    Jun 8, 2015
    Messages:
    1
    Likes Received:
    0
    Hi guys,

    Am having the same issue - its a company policy thing but they have not provided us with drives to backup data and files so have taken to using my own personal drive.
    Since its personal - I don't want bitlocker on my drive :(

    tried mkztg route - to no avail.
    Have also tried the solution given by jafar - still not working
    is there any executable that anyone has that can do this for me?
     

Share This Page

Loading...