Bitlocker denying write access to usb thumb drive

Discussion in 'Windows 7 Help and Support' started by jaf2000, Mar 21, 2012.

  1. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    I have Windows 7 installed and up until recently I could read and write files from my hard disk to my usb thumb drive. Now after some updates were downloaded and applied (automatically so I am not sure what was installed), when I insert my drive into the usb slot, the Bitlocker Drive Encryption window pops up and I have two choices. Encrypt this drive to allow write access or don't encrypt this drive but it will be read only. I checked Control Panel -> Bitlocker and it says its off my for C drive and my usb thumb drive. So i'm not sure why its wanting to encrypt it. How do I get rid of this Bitlocker and gain write access to my usb drive?
     
  2. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    You should have a BitLocker key somewhere, either printed, or in your documents somewhere, or on another device. Do you have a copy of that key?

    This happened to me once, and I had to fiddle around half the day to get BitLocker to working again. Also, you should go into Services & make sure that BitLocker drive encryption is turned on.

    My suggestion is once you gain access to your flash drive, is to dump BitLocker & go with True Crypt. It's far better protection/encryption & you can access your flash drive on any computer that has True Crypt in the Documents folder (it doesn't have to be installed on the system. BitLocker is computer dependent.

    TrueCrypt - Free Open-Source On-The-Fly Disk Encryption Software for Windows 7/Vista/XP, Mac OS X and Linux

    Looks a bit complicated at first glance, but it's actually easier than BitLocker to use.

    Cat
     
  3. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Thanks. But the thing is, I never enabled Bitlocker, never set any key or anything. So not sure why all of a sudden its asking to encrypt my usb thumb drive. My hard disk is not encrypted and yet I can write to it.

    I basically don't want Bitlocker installed. So how can I tell Bitlocker to go away and not refuse write access to my usb drive?
     
  4. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    Have you tried placing this drive in another computer to see what happens?

    What you can do, is make sure that BitLocker is disabled in Services. Type "Services" into the Start Menu (w/o the quotes), go down the list, you'll see "BitLocker Drive Encryption" as a Service. Disable it.

    If that doesn't solve your issue, along with checking it on another computer, check the Properties of the Flash drive & see what it says. Too, a reboot may clear things up.

    Cat
     
  5. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Hi, yes I placed it into another computer and Bitlocker did not come up. I was able to write to the drive.

    I then followed your instruction and disabled the service and even rebooted. I did get a bit further. The Bitlocker message that used to pop up asking me to encrypt the drive did not pop up again.

    However when I went to copy a file to it, Windows 7 said the drive was write protected. So something else is going on.

    Seems like i'm halfway there. What could be mistaking it as a write protected drive?
     
  6. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    Does anyone other than you have access to this flash drive? The only thing that I can come up with is that someone encrypted this drive.

    My solution: Copy the contents to a folder somewhere, everything that you want. Then format the drive, a quick one is OK. Make sure that you select the same file system (NTFS, FAT32, exFAT) when formatting the drive. Then, you should be able to use it again properly.

    For your protection, it's my suggestion that you check out the TrueCrypt software that I linked above, you can use it w/o installing it onto your system. But the program files for it to work must be in your Documents folder (or other folder of your choosing). This will prevent the unauthorized access of the drive.

    Cat
     
  7. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    I'm the only one with the access to the USB drive and the windows 7 system.

    I'll give the format a try and let you know how it goes.

    In checking the USB drive it was formatted with FAT32.

    Thanks for the help everyone.
     
  8. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Ok I attached my usb drive onto another system, copied over the files, reformatted it as FAT32. Then I put the usb drive back on my windows 7 system and still the windows 7 system marked it as write protected. So I put the files back on with my other systems.

    I'm stuck on this. What could be making my Windows 7 mark the usb thumb drive as write protected?

    Is there any way to remove bitlocker? I'm not sure if bitlocker is the suspect here or not. I really need to get it to see it as read/write.

    Would formatting it as NTFS work?

    This is frustrating as the windows 7 system is my main computer.
     
  9. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    This one, is puzzling to me. Seems that a format would have reset the USB drive, and unlocked the write protection. The only option that I know of.

    Hopefully, other members will throw in a word on this. These type of things are a PITA!

    Cat
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Can we assume that there is not a physical switch or button or other means of write protecting the drive in question? I do remember some of the older drives have such sliders to prevent accidental over writing of files.
    If you look at the drive from within disk management how does it appear? Is there more than a single partition? Does the drive contain some factory software from the drive vendor including its' own management utilities.
    Perhaps if you could provide some specifics as to the Manufacturer, Model Name, Model Number, Size, etc., someone may have some additional information specific to that device.
    And by the way....... welcome to the forum.
    Randy
     
  11. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Hi Randy,

    Thanks for the welcome.

    It definitely does not have a physical switch or button to lock it. I can have all 3 systems right next to each other (windows 7, XP,. 2008) and plug it into the three of them. Only Windows 7 sees it as write protected.

    It is a SANdisk Cruzer 16GB SDCZ36-016G

    Disk manager on XP shows 1 partition. It does have its own U3 program on it.

    It used to work fine on the Windows 7 computer until recently. I know the day that it started happening on the Windows 7 laptop, there were some updates that were downloaded that morning. Prior to that, I was using it frequently without fail. So to me, something had to have changed on the Windows 7 side.
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I have practically the same device SanDisk Cruzer Micro 16 GB SDCZ6-016G. The first thing I did when I got it was wipe it completely including the proprietary U3 directory and formatted NTFS. Mine works without issue both on Windows 7 and Windows 8 machines and really anything else I plug it into.
     
  13. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    2 of mine are the SanDisk Cruzer 4GB SDCZ36-004G-A11C. Both are still running well, even with the U3 software on it. I left the U3 on because of it's password protection. They were good buys at the time (2010), $4.99 for each.

    And they both work on any Windows OS that I've used them on. I just wonder, if that U3 software became corrupt somehow.

    Cat
     
  14. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Ok, I formatted my usb drive (I copied the contents to another system) on my 2008 system and selected NTFS. I then took the empty usb drive and put it on my windows 7 system and tried to copy a file to it. I again got the write protected message.

    If my windows 7 system had a neck I'd be strangling it right now.
     
  15. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Open Computer and right click the drive and choose properties. See if you can find anything anywhere that has a read only attribute assigned or checked.
    Open the drive in Computer and see if you can right click and choose New->Folder. If you can create a new folder see if you can write a new file inside that folder.
    Likewise open device manager, expand disk drives, right click the SanDisk and choose properties, look under the Policies tab and see how it is defined (Quick Removal or Better Performance) try switching that and see if that changes anything as to how it behaves and then switch it back just for testing.
     
  16. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Two things I would suggest. Insert the flash drive and open an administrative command prompt. Then type this command, which gives the status of Bitlocker:

    Manage-bde -status

    This should give you a readout and if Bitlocker is off, it should say so. Has the device ever been used with a Bitlocker system?

    Second, if the drive contains no data, use Diskpart to clean it and perhaps that would wipe out anything that might be left. You can also do this from an administrative command prompt, but make very sure which drive you are working on. You will have to reformat after.

    If you right click the drive in computer, and check properties, does the security tab show you having full control?

    Bitlocker command reference:

    Manage-bde.exe Parameter Reference
     
  17. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I know SanDisk included proprietary encryption software (CruzerLock and CruzerLock2) on some of their legacy drives as well as Encryption capability with their newer drives included with their proprietary SanDisk Backup software. If you have employed any of these products, that may account for some of the issues you are having. But since the drive seems to work without issues in you other machines then is is more likely something unique to either your Windows 7 OS or its' configuration.
    While looking around and researching the issue I came across this information How do I remove write protection from a USB memory stick? - Windows-XP-General-Discussion - Windows-XP
    There is mention of a utility from Apacer which some have found helpful as well as reference to a specific registry key. Give it a read and see if anything there might be useful.
    Regards
    Randy
     
  18. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    Ok here is what I did.

    1. Dug out an old USB Sandisk 1 GB flash drive. No system contents on it, no U3 or anything like that on it. Connected it to Windows 7, said it was write protected.
    2. Connected that same disk to the 2008 system, I can write to it.
    3. Went to Start -> Control Panel -> Bitlocker Drive Encryption and found it was turned off for the hard disk and my usb drive
    4. Executed Start -> Run -> cmd -> diskpart. Selected my usb drive volume. Checked the attributes and Read only was set to NO on both disk and volume.
    5. Manage-bde -status shows its off
    6. Went to HKLM\System\CurrentControlSet\Control\StorageDevicePolicies, created a DWORD WriteProtect, set it to 0 and rebooted. No change in behavior.

    Weird. Now i'm wondering if some sort of policy is defined.

    I did check the properties on the usb drive. There is no policy tab either.
     
  19. jaf2000

    jaf2000 New Member

    Joined:
    Mar 21, 2012
    Messages:
    20
    Likes Received:
    0
    An update. I went through the entire gpedit.msc and no policy is enabled that would cause this.

    Anyone know of a registry entry issue or a usb driver issue?

    I did try the HKLM\System\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect=0 and it did not help. I also made sure all other control sets had that setting. I wonder if there could be another registry setting.

    Anyone have any other ideas?
     
  20. catilley1092

    catilley1092 Extraordinary Member

    Joined:
    Nov 19, 2010
    Messages:
    1,034
    Likes Received:
    46
    You mentioned something about this happening after applying the updates on Windows 7. Is System Restore (the point that your issues arised) an option for you? You could try it, and if it doesn't solve the problem, it can always be reverted back.

    If it does work, then you'll know not to have that flash drive installed while updating.

    Cat
     

Share This Page

Loading...