BSOD after installation of Windows 7 64 bit

#1
Hi all,

I hope you can help me to solve my problem:

The Bluescreens began after i installed Windows 7 64Bit Ultimate on my Computer, before that i had used Windows 7 32 bit Ultimate and i hadn't any problems. I installed the latest driver for all my components, but this didn't help. I also ran Memtest86+ with no ram errors. The Bluescreens appears often when I'm playing Starcraft 2 or Battlefield Bad Company 2.

Here are the my System Specs:
Motherboard: Gigabyte GA-870A-UD3
Processor: AMD Phenom II X4 955
Graphic Card: AMD Readon HD 6870
Memory: Geil Value Plus DDR3 PC3 1066 1333MHZ 4GB Kit
Power supply: Cougar SE 400

I have attached the minidump files, the RAMMon-SPD-Info, an the CPU-Z Memory Infos View attachment RAMMon - SPD Info.txt
 


Attachments

Captain Jack

Extraordinary Member
#2
Hello there!

Seems like the dump files weren't very helpful. But first I would recommend to reinstall your Direct X drivers and Reinstall your display drivers as well. Go follow this link Hardware Diagnostic | Captain Debugger and run a complete Hardware Diagnostic (Especially the video stress tests)

Uninstall AVG completely and run the removal tool to left over files

Code:
PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: ffffda8004335950, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff800031c4dd3, If non-zero, the instruction address which referenced the bad memory
    address.
Arg4: 0000000000000007, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS:  ffffda8004335950 

FAULTING_IP: 
nt!ExFreePoolWithTag+43
fffff800`031c4dd3 418b45f0        mov     eax,dword ptr [r13-10h]

MM_INTERNAL_CODE:  7

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  BFBC2Game.exe

CURRENT_IRQL:  0

TRAP_FRAME:  fffff8800d84b3d0 -- (.trap 0xfffff8800d84b3d0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=ffffda8004335960
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800031c4dd3 rsp=fffff8800d84b560 rbp=0000000000000001
 r8=fffffa8004229080  r9=0000000000000020 r10=fffff8000320c760
r11=fffffa8004335940 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po nc
nt!ExFreePoolWithTag+0x43:
fffff800`031c4dd3 418b45f0        mov     eax,dword ptr [r13-10h] ds:ffffffff`fffffff0=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003043357 to fffff80003098d00

STACK_TEXT:  
fffff880`0d84b268 fffff800`03043357 : 00000000`00000050 ffffda80`04335950 00000000`00000000 fffff880`0d84b3d0 : nt!KeBugCheckEx
fffff880`0d84b270 fffff800`03096e2e : 00000000`00000000 ffffda80`04335950 00000000`00441000 fffffa80`04335980 : nt! ?? ::FNODOBFM::`string'+0x44811
fffff880`0d84b3d0 fffff800`031c4dd3 : 00000000`00000000 fffff8a0`05974910 00000000`6d4d6956 fffff880`00000174 : nt!KiPageFault+0x16e
fffff880`0d84b560 fffff880`02d225fd : 00000000`00000000 00000000`00000001 fffff8a0`6d4d6956 00000000`00000174 : nt!ExFreePoolWithTag+0x43
fffff880`0d84b610 fffff880`02d08ecc : 00000000`00000000 00000000`00000000 fffffa80`03c73450 00000000`00000000 : dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+0x275
fffff880`0d84b6e0 fffff880`02c4accc : 00000000`00000000 fffff8a0`09869000 fffff8a0`09869000 00000000`00000001 : dxgmms1!VidMmCloseAllocation+0x44
fffff880`0d84b710 fffff880`02c4a65f : fffff8a0`09869000 00000000`00000000 fffffa80`00000000 00000000`00000000 : dxgkrnl!DXGDEVICE::DestroyAllocations+0x248
fffff880`0d84b800 fffff880`02c4aa03 : fffff8a0`09869000 fffff8a0`09869000 00000000`00000001 00000000`00000000 : dxgkrnl!DXGDEVICE::ProcessTerminationList+0xa3
fffff880`0d84b850 fffff880`02c4e79c : fffff8a0`0aa96500 fffff880`0d84bca0 fffff8a0`09869000 fffff880`02c153af : dxgkrnl!DXGDEVICE::TerminateAllocations+0x1db
fffff880`0d84b8a0 fffff880`02c50e57 : fffff8a0`09869000 fffff880`0d84b9b0 00000001`40000e01 00000000`5b2e3101 : dxgkrnl!DXGDEVICE::DestroyAllocation+0x448
fffff880`0d84b930 fffff960`001dde5e : 00000000`ffe94000 fffffa80`03cd4060 00000000`00000020 00000000`73445f08 : dxgkrnl!DxgkDestroyAllocation+0x9bf
fffff880`0d84bbf0 fffff800`03097f93 : 00000000`1305fdc8 00000000`0780e801 fffffa80`05840b40 fffffa80`00004000 : win32k!NtGdiDdDDIDestroyAllocation+0x12
fffff880`0d84bc20 00000000`7346120a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0780e7e8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7346120a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+275
fffff880`02d225fd 33d2            xor     edx,edx

SYMBOL_STACK_INDEX:  4

SYMBOL_NAME:  dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+275

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgmms1

IMAGE_NAME:  dxgmms1.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4ce799c1

FAILURE_BUCKET_ID:  X64_0x50_dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+275

BUCKET_ID:  X64_0x50_dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+275
 


#3
thank you for the fast reply,
i have run memtest over night with no errors,
also furmark was running over two hours with no problems, my graphic card reached a maximum temperatur of 70°C
but today the same happened again, while i was playing battlefield :S

now I'm removing AVG and hope that the problem will be solved

edit:
Removing AVG didn't help
 


Last edited:

Mike

Windows Forum Admin
Staff member
Premium Supporter
#4
An analysis of these minidump files indicate a consistant issue with both the graphics (ATI) display drivers and DirectX. You should make an effort to completely ensure that your video graphics card drivers are up-to-date and that the physical device is seated properly with enough power going to the graphics card.

If you continue to experience this problem, I would recommend performing a full audit of all graphics related hardware and software on your system.

Basically, the kernel of the system is faulting, according to the BSOD read-out. During most of these failures, we are seeing a PAGE_FAULT_IN_NON_PAGED_AREA and IRQL_NOT_LESS_THAN_EQUAL involving dxgmms1.sys, atikmdag.sys, ntoskrnl.exe, usbport.sys, hal.dll.

Here is what this tells us:


  • The NT kernel is crashing. This results in the blue screen.
  • Memory allocation errors are occurring that could be related to graphics hardware or drivers.
  • In at least one specific instance, Catalyst Control Center (CCC) drivers are involved in the crash.
  • In at least another specific instance, the USB port control driver is related in the crash.
  • There is evidence DirectX errors are causing the system failures, but this would mostly be related to your video graphics card and not necessarily DirectX itself.

This makes sense in the fact that the system is crashing while you are playing games. If you are using a USB device while in the game, such as a gamepad, this would explain why the USB driver appears in the crash at least once.

Recommended solution:

Check some information regarding the files listed above. Some claim they have found a solution to the problem in some instances.

Use System File Integrity Checker (SFC /scannow) to ensure that the problem is not related to corrupt system files.

Completely uninstall all ATI related drivers properly using the methods listed here.

Re-install the latest drivers using the above listed methods.

My AMD/ATI Radeon HD 6850 card is running at 45 C on idle. If you are tasking your set up, you may in fact go up to 60 C, but not on idle. If you continue to experience these errors, you should check the seating of the physical card, remove all unnecessary devices from the system, consider checking for additional driver updates. But, all indications seem to reveal a problem, not with the memory itself, but with the allocation of memory when the video card is in use. This would be indicative of a problem with the graphics hardware.

Of course, one way to determine if your graphics card is at fault would be to swap it out with another, or test the existing graphics card on a different computer. Since this is very likely to be impossible, you should use the above steps to come to your own conclusion. However, I would suspect that video card could be at fault in this instance.
 


Captain Jack

Extraordinary Member
#5
I would also recommend to look into your Power supply for such PC configuration I don't think 400W is enough.
 


#6
I removed the ATI driver for my graphic card, and used the windows 7 drivers, but the Bluescreen appeared again while playing the game :S.

@Captain Jack
I don't think that 400W isn't enough for my system, because I used Windows 7 32 Bit for an year with no problems, I think there are any problems with the 64Bit version
 


#7
I don't think that 400W isn't enough for my system, because I used Windows 7 32 Bit for an year with no problems, I think there are any problems with the 64Bit version
The X64 version doesn't use any more power versus the X86. However, I do agree with Captain Jack that you really should upgrade your PSU to a minimum of 500-600 watts. Preferably to one that is at least 80 Plus Bronze Certified. You can find many good PSU with that rating for around $55-75 dollars.
 


#9
I reinstalled windows again, but the problem again appeared. I also used the power supply calculator, and my recommend PSU Wattage was 368W; I'm using a 400W power supply. I think I'm going to boost the voltage of my ram to 1.60.
 


#10
Here are all my minidump files, including the old and new ones.
 


Attachments

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#11
I've seen your exact problem somewhere else and it was solved. I'll go look for it and post back asap.
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#12
Ok when you installed the catalyst drivers did you do the sb chipset package? Are you laso by any chance using the sata in AHCI mode?
 


#13
I have changed the sata mode from IDE to AHCI, and I changed the command rate to 2T. In other forums they told me, that a command rate of 1T is the problem of the bluescreens. I will report later if the bluescreen happens again.
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#14
1T wouldn't be good. Hope it's solved your problem.
 


#15
So now i don't really know what i have to do. I thing my graphic card is the fault :S. I changed the command rate to 2, and i raised up the voltage to 1.64V.
I still have warranty on my graphic card, should i replace it?
 


itayk

Well-Known Member
#16
Dude, I have the exact same issue! I have a Sapphire HD6850 and I'm getting crashes when playing games or even watching Youtube. Do you get crashes sometimes while watching Youtube?
 


#17
That happened to me yesterday for the first time, i was watching a video in youtube, and after i wanted to close the browser i got that bluescreen.
 


itayk

Well-Known Member
#18
Well, I found the problem: The driver of a USB Wi-Fi device I plugged in caused the computer to crash.
Apparently, it's an old vista driver that's not suitable for Windows 7 64Bit.
Installing a different Wi-Fi adapter solved the issue for me.

You can check it as well if that's the case for you.

I recommend a software called "BlueScreenView" which tells you what file caused Windows to crash.
 


zigzag3143

Honorable Member
Microsoft MVP
#19
Thanks for reporting back. Should help others in the future.
 


#20
Actually i didnt't have any Wi-fi device, I'm using ethernet lan. However the problem still exists :S. I'm looking foward to replace my graphic card.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.