BSOD THREAD_STUCK_IN_DEVICE_DRIVER ATI (dxgkrnl.sys + hal.dll + atikm

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#41
Please let me know how you get on and good luck!
 


Kaper

New Member
#42
Hi kemical. I am still in testing phase, so i can´t say for now, if the new GPU solved the problem, but from 19.05.2016 until now i didn´t had any freeze at all. So it seems fine.

But what i found? It may be interesting, and if I can confirm that my system with the"new" GPU is 100% stable i will do following changes, which you can see here.
I found that ASUS HD 7790 seems to have some problem with low memory clocks when idling and it causes freeze.
See here: ASUS R7 260X DC2-OC-2GD5 - Power Management Tweaker - Guru3D.com Forums

It is power management tweaker, and it looks, that it may solve the issue. What you think about that?

I can´t test it now, because i am testing new GPU at the momment. /(sorry for my eng, i hope you can understood :))
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#43
Hi kemical. I am still in testing phase, so i can´t say for now, if the new GPU solved the problem, but from 19.05.2016 until now i didn´t had any freeze at all. So it seems fine.
Excellent news!

I found that ASUS HD 7790 seems to have some problem with low memory clocks when idling and it causes freeze.
See here: ASUS R7 260X DC2-OC-2GD5 - Power Management Tweaker - Guru3D.com Forums
Interesting! So this application was created for this card specifically.. Hmm. I would definitely try it for sure..
(I'm making a note of this application as it seems very handy thanks)
Nice find by the way!

Please let us know how you get on with the rest of the testing.. Thank you :)
 


Kaper

New Member
#44
Hello guys.

I have one bad and one good news.

The bad news is, that i Can´t 100% confirm that i have no freezes at all.

The good news is, that I used Power management tweaker from Guru3D and i set my ASUS HD 7790 to clocks 1100/1625 (Stock is 1075/1600) and I also set #State 1 lowest memmory clock to 600MHz and it seems, that it helped!
Till now, i was using card with these clocks more than 5 days.

Only after a few weeks, I can say if it is 100% stable or not.
 


Attachments

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#45
Hi Kaper,
sounds like your getting somewhere and the reduced clocks has worked for a number of users with these types of issues. Out of interest how old is the 7790?
 


Kaper

New Member
#46
This problem seems to have just ASUS HD 7790

TechPowerUp ASUS HD 7790
Released: Mar 22nd, 2013

Here is reference / stock HD 7790 (TechPowerUp)

It is interesting, that I own this card more than 2 years and i thought my BSOD are caused by CPU Overclocking or anything else...
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#47
Hi Kaper,
I suggested this solution to other users before although I can't remember if it was the same card lol.. I'll certainly remember for next time tho!
 


Kaper

New Member
#48
Hello, unfortunatelly i am here back again.
After 17 days i got BSOD when i gone afk from PC....
Now i am testing new power settings on my GPU.

My current settings: ( I changed lowest Memmory clock from 600MHz -> 900MHz)
 


Attachments

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#49
Hi Kaper,
can you post the dump file too please?

Regarding your clock speeds, are you saying above your settiing the memory clock back up to 900mhz after reducing it down to 600mhz?
 


Kaper

New Member
#50
Like i said, now I am testing memory frequency on 900MHz (minimum state)

Sure, here is the dump:
 


Attachments

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#51
Like i said, now I am testing memory frequency on 900MHz (minimum state)
Oh I see... Hadn't drunk enough coffee earlier.. :)

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 100000EA, {ffffe001602df840, 0, 0, 0}

*** WARNING: Unable to verify timestamp for atikmdag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmdag.sys
Probably caused by : dxgkrnl.sys ( dxgkrnl!TdrTimedOperationBugcheckOnTimeout+24 )

Followup: MachineOwner
Well as you can see it's still the same Bugcheck which basically means either a faulty driver or faulty card is to blame.

See how you go with the testing. Perhaps you can get it to stable clocks?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.