Cannot Install Epson Scan Utility

Cheemag

Honorable Member
#1
Windows 7 Home Premium 64-bit. Epson Stylus SX218.

Hello again,

Windows lost the use of the printer. Deleted the printer and reinstalled it from the CD.
Printer works, copier works but scanner will not install. It exits from Epson's install programme with 'an error - restart please'. After restart same.

Downloaded everything for Win 7-64 from Epson. Same result with scanner. Windows went looking for drivers, found one for the printer but not for the scanner. I'm fairly sure the driver is on the HD as well as on the CD, but for some reason it can't be installed. An 'Epson Scan's' icon on the desktop points to an .EXE file which looks like a driver, but does nothing when clicked. Unfortunately I deleted the icon!

There is only the printer in Geek Uninstall, no scanner, so presumably the scanner isn't installed unless the driver is in place first.
 


Cheemag

Honorable Member
#3
I've been there and downloaded the latest driver and driver installer. The installer goes well until, with one minute remaining to finish, it stalls for several minutes then says the install failed and to restart. The printer driver then installs OK.

This process puts an icon on the desktop entitled 'EPSON Scan' which shortcut points to:
C:\Windows\twain_32\escndv\escndv.exe which may or may not be the offending driver.

Fortunately it's not a big problem as I don't scan much and have another AiO printer on another machine, but it's annoying.

Regards

Cheemag
 


Cheemag

Honorable Member
#4
Went to Device Manager, initiated a driver update, pointed Windows to the driver on the CD and it all now works.

Cheemag
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top