Can't boot into Windows after running BitLocker

PKM1111

New Member
Hello. I have 3 drives in my PC:
  • SSD with Ubuntu
  • HDD for downloads etc. - no OS
  • HDD with Windows 8.1 partition & Windows 7 partition & 1 empty partition
When I start my PC, the GRUB2 menu shows up and I can choose whether I run Ubuntu or Windows. When I choose Ubuntu, it normally starts up. When I choose Windows, I'll get into Windows multi-boot graphical menu and there I can decide between 7 or 8.1. Like this:


However... Today, I decided to encrypt my Windows partitions with BitLocker. So I booted into W8.1 and encrypted W7 partition with no problem - after restarting, I got into GRUB2, selected Windows, got into Windows multi-boot graphical menu, chose W7, entered newly configured BitLocker password, and it booted / started flawlessly.

Then, in W7, I was going to encrypt W8.1 partition. There was the first problem - when I right-clicked W8.1 partition, there was no "Turn On BitLocker" option. I tried to encrypt it thorugh the Control Panel, but even there was no W8.1 partition shown. Then I tried allowing no TPM devices to be encrypted, but problem still persisted.

Weird thing was that when I booted into W8.1 and right-clicked its partition, the BitLocker option was there (I do not have a clue why I could encrypt W7 partition from W8.1, but couldn't do it vice-versa??). So I run BitLocker from W8.1, but it was slightly different from before - when I was setting it up for W7, it only asked me for password, but now it said:
An existing drive or unallocated free space on the hard drive will be use to turn on BitLocker.
I did not have a good feeling about it from the start, but after small research I realized that I probably don't have any other options, so I risked it. BitLocker began shrinking partition and preparing it. When the process was complete, it prompted me to restart computer.

I can't boot into neither W8.1 nor W7 since I restarted. After choosing Windows in GRUB2 menu, I'll get into black screen with message
An operating system wasn't found. Try disconnecting any drives that don't contain an operating system.
Press Ctrl+Alt+Del to restart.
I checked HDD in Ubuntu. BitLocker cut ~350MB from W8.1 partition and created new partition from it. The new partition also had a boot flag. So I thought maybe if I deleted this newly created BitLocker partition and set the boot flag back to W8.1, everything would go back to normal. It didn't work. And there's another weird thing - in GParted there's a red exclamation mark next to it, and it also can't see how much space is free / used:


The last thing I tried was creating bootable Windows USB > Repair system > Command Prompt:
Code:
bootrec /fixmbr
bootrec /fixboot
bootrec /scanos
bootrec /rebuildbcd
While /fixmbr and /scanos worked, /fixboot is outputting "Element not found." error. /rebuildbcd found just one Windows installation instead of two and after I pressed Y to add at least that one to BCD, there was the same element error. The very last thing I did was running diskpart and activating both Windows partitions. As you can excpect, nothing was solved.

Can some here know what else should I try to get it back to normal?
 

Neemobeer

Windows Forum Team
Staff member
It possible that grub doesn't know where the boot entries are for Windows. I would boot into Ubuntu and re-install grub. sudo grub-install /dev/drivename(typically sda)
 

PKM1111

New Member
I did it and now I don't have a Windows option in GRUB at all :( I suppose that bootloader for both Windows 8.1 and 7 is completely broken, so GRUB couldn't find it.
 

Neemobeer

Windows Forum Team
Staff member
You may need to look in your grub config file and make sure it is configured to detect other OSes it may have been reset after re-installing it. Then run sudo update-grub.
 
Top