Can't disable sleep, or password on wakeup

#1
I have Windonws 7 Professional running on several virtual desktops (VMWare View). The virtual desktops go to sleep after a few minutes, and require a password on wakeup.

I've read a number of threads that deal with either disabling password on wakeup, or preventing the OS from going to sleep altogether. The problem is that all of those solutions refer to settings options that I don't have.

Two examples:
  • If I open the Power Options control panel, there is no 'require a password on wakeup' option in the left-hand frame.
  • If I go into the advanced settings for any of the available power plans, the only option under Sleep is 'Allow wake timers'. There is no 'Sleep after' or 'Hibernate after' option to change.

How can I stop these machines from sleeping, or at least stop them from requiring a password on wakeup?
 


davidhk129

Senior Member
#2
Do you have screensaver enabled ?
Are you sure it goes to "sleep" mode, not to screensaver mode ?

Right click at an open spot on your desktop > select Personalize > bottom right is Screensaver option....
is there a "stop sign" over the icon, and the word "None" under Screen Saver?
If no, disable screensaver by ......
click Screen Saver option > under Screen Saver heading, click the pointer to see the list > select NONE > click OK when done.
 


Trouble

Noob Whisperer
#3
I have Windonws 7 Professional running on several virtual desktops (VMWare View). The virtual desktops go to sleep after a few minutes, and require a password on wakeup.

I've read a number of threads that deal with either disabling password on wakeup, or preventing the OS from going to sleep altogether. The problem is that all of those solutions refer to settings options that I don't have.

Two examples:
  • If I open the Power Options control panel, there is no 'require a password on wakeup' option in the left-hand frame.
  • If I go into the advanced settings for any of the available power plans, the only option under Sleep is 'Allow wake timers'. There is no 'Sleep after' or 'Hibernate after' option to change.

How can I stop these machines from sleeping, or at least stop them from requiring a password on wakeup?
See attachment
 


Attachments

#4
Thanks, guys.

Trouble, I don't have that option.

David, I feel like an idiot now; it it was the screensaver. Still not out of the woods, as the screensaver options are all greyed out, but I can probably get around that in the registry.
 


davidhk129

Senior Member
#5
Thanks, guys.


David, I feel like an idiot now; it it was the screensaver. Still not out of the woods, as the screensaver options are all greyed out, but I can probably get around that in the registry.

See if this tutorial can help...... it allies to Vista, Win 7 and Win 8.
http://www.sevenforums.com/tutorials/132549-screen-saver-enable-disable.html
 


#6
Thanks again, David. I figured out how to disable the screensaver in the registry, and that fixed the problem for my golden image, but after recomposing all of my virtual desktops, they continued to lock.

All I can figure is that it was related to group policies. After a little more research, I set up a GPO that explicitly disables the screensaver, and now the virtual desktops are working like I want.
 


davidhk129

Senior Member
#7
Glad to know you have it sorted.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top