Can't install ATI graphics drivers

#1
When I try to install ATI Catalyst, I keep getting an error message that says "Driver Install: the specified driver package was not installed for matching devices." I've tried installing the full-fledged catalyst suite and just the basic driver, but both with no effect.

I'm using the Vista 64 bit drivers. I used the Vista drivers successfully in the previous version of Windows 7, but it was the 32 bit version. Would installing the 32 bit Win7 over the 64 bit make the Vista drivers work, or is it an issue with the new version of 7?

Thanks,
Andrew
 


reghakr

Essential Member
#2
From what I've read it relates to an InstallShield error. The driver is not signed by Microsoft.

EDIT: Important:

These drivers have just been released and they are for the 64-bit OS

http://game.amd.com/us-en/drivers_catalyst.aspx?driver=VideoCard/win7-64-suite

Make sure you download the bottom driver, the WHQL-certified one.

It also uses a file in the system32 directory named difxapi.dll

On my 32-bit machine the file properties state:
File version: 2.1.1.0
Size: 308KB

Yours should be different in size.

Did you do a "clean" install? If not, that could be the problem right there.

I do not recommend installing the 32-bit version "over" the 64-bit OS. You are asking for trouble there.
 


Last edited by a moderator:
#3
Well, when I said install OVER the 64 bit, all I really meant was install it over the partition where the 64 bit currently is, but still installing from scratch.

Unfortunately, those drivers didn't do anything. I didn't get any errors after the installation, but I also didn't get any drivers. They installed, or at least the install said it was installed, but 7 doesn't seem to recognize it.
 


#4
The Catalyst Control Center never worked for me. I just let W7 install a driver automatically and it worked. Might not be working with W7 yet.
 


#5
The only drivers 7 will automatically install are the "generic" drivers which don't let me bring my resolution above 1024x768 or use a second monitor. And, Aero or anything else remotely video-intensive is completely out of the question.
 


#6
The only drivers 7 will automatically install are the "generic" drivers which don't let me bring my resolution above 1024x768 or use a second monitor. And, Aero or anything else remotely video-intensive is completely out of the question.
Hmm that sucks. Everything worked for me with the generic drivers. Sorry I couldn't help.
 


#7
The really weird thing is that the generic drivers worked fine in the beta release, as well as the Vista drivers. I don't know why they don't now.
 


loathe

New Member
#8
Are you trying to install the lastest 9.4 drivers? They are broken.. I have a fix if you are
 


#9
try this out... DriverMax - FREE driver download program for Windows XP & Vista

i also have a vostro 1000. mine worked just fine through all the builds until RC. what i did (and it takes time but solved the issue for me) is install vista. take the driver from vista. put it on an external HD. installed 7. loaded driver from the extenal HD and enjoyed aero. hope it works for you
 


#11
I've tried 9.3 Vista and 9.4 7, so yes. Where can I find the fix?
 


loathe

New Member
#12
Alright so catalyst control center installed alright just no driver? Go into device manager and right click your dispaly adapter driver software and hit update. Click browse my computer. Then let me pick from a list.. and then click have disk.

Then you want to browse to:

C:\ati\support\your newest driver package\driver\packages\drivers\display\LH6A_INF and then choose the bat file with the highest number.

Should then install the driver you need if your card supports it. I also had to do this for 9.4

Good luck
 


#13
There's no Xpress series listed anywhere in those lists. Does that mean ATI isn't supporting Xpress for 7?
 


loathe

New Member
#14
Maybe not. The only driver listed is the Vista x64 9.3 one yeh? Having said that it should work.

The only other thing I can think of is uninstalling the drivers and put this command in the command promt
bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS
restart and try installing the x64 Vista driver in compatibility mode

http://support.amd.com/us/gpudownload/windows/Legacy/Pages/integrated_vista64.aspx
 


#15
Ok, 9.3 didn't work, but based on the things you've been telling me and the fact that a Vista driver should theoretically work, I figured if I go back far enough it should start working.

To make a long story short, I tried Catalyst 8.12 and, as if by magic, it's working perfectly.

Thanks a whole bunch, I could never have done it without your help.

Edit: Well, it's running pretty slowly, but at least it's definitely an improvement. Maybe I'll mess around with it later to get it running better once I have things set up.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.