Can't install Wireless Drivers

#1
Hello there. I recently just built a new pc and decided to buy a new 500gb sata drive to go with my new version of Windows 7. I've been using windows xp for a decade now and generally know it pretty well.

Under device manager the only thing that wouldn't install is my wireless card, now it works fine with Xp but windows 7 won't pick it up at all. I've used the disk that came with it and tried various drivers across the internet.

The card I'm using is a Atheros ar5005g, trying to install it on Windows 7 - 64 bit home basic. Now the drivers I've tried installing I've used their installer and that installs fine, but under Device manager it still says my ethernet device has no drivers installs. When I try to scan for available drivers by right clicking the device and browsing to the folder, Windows 7 says there's no available drivers. This even happens with the install disk (which I know would have out of date drivers) but windows 7 just refuses to install the drivers.

I'm a bit at an end already at what to do? If anyone could hlp me out, I'd greatly appreciate it.

Thanks very much,

Nigel
 


#2
Well also, the model name on the actual card is a Belkin F5D7000E. But when it's installed on windows xp it's listed as a Atheros ar5005g.

Not sure if that's any help?

Cheers
 


#3
Visit the manufacturer's site for the newest driver. Use Vista x64 if there is no 7 x64.

If you still can't get it to install in the normal method:

In device manager, right click the device. Update driver software. Browse my computer. Let me pick. Have disk. Browse.

Now find and double click on the .inf in the driver folder. Hit ok. Hit next and it will install.
 


#4
I've found another driver to try, shall try it later. Was reading the right click> compatability thread too. But the thing is about the right click device> update browser software, even the original CD when I browse too it, Windows 7 won't pick up the drivers.

I shall try a the new driver and hope for the best
 


#5
You'll gain the best results by visiting Belkin's site to obtain the latest driver. Install using my instructions if need be.

You really don't want to install anything else as wireless drivers tend to bsod systems really quickly, when they are not the latest.
 


#6
It just refuses to install any drivers, even tried this fix Belkin FSD7050v4 driver for Windows 7 - FixYa

I know it's a slightly different card, but the drivers are supposed to be the same. No drivers I've tried, no compatibility mode I run it under, it still comes up "The drivers for this device are not installed".

I'm a bit confused in one sense though, when the Wireless card is installed on XP, under device manager it's listed as Atheros AR5005G Wireless Network Adaptor, but on the device it's it's label states it's a Beklin F5D7000 E. I've tried the Belkin drivers to no avail, should I try Atheros Drivers? (I did previously but not in compatibility Windows Vista)
 


#7
just found this thread:

http://windows7forums.com/windows-7-networking/21018-f5d7000-e-troubles.html

Which basically states that this card is a deadend with windows 7, looks like I'm gonna have to buy a new wireless card. Cheers TorrentG for the help, appreciate it.

I'll keep looking for a solution at the minute but it seems highly unlikely.
 


#8
I could probably make a driver for you, but then you'd have to disable driver enforcement on a permanent basis or each time you start the machine, by hitting f8 and choosing to do so - since you're on 64 bit.

I recommend to purchase a new card though. If you want to see if there's anything I can do, a little info will be necessary. Open device manager. Double click the adapter under network adapters section. Properties. Details tab. Change the dropdown to hardware ids. Copy/paste results to here.
 


#9
Fixed it! Phew, seems like many a person around the internet has had similar trouble and it's serious shenanigans finding a solution but this one worked for me:

Taken from this thread: windows 7 and the F5D7000 wireless card question

"1) Go to the start button, push it
2) RIGHT click computer
3) LEFT click properties
4) Now look to the plane on the left of the window that just popped up.
5) LEFT click Device Manager
6) Now click on the arrow next to the Network Adapters catagory (OR)
look for the Network Card that had the yellow exclamatory sign next to it
7) RIGHT click on it
8) LEFT click Update Driver Software...
9) Choose Browse my computer for driver software
10) Choose Let me pick from a list of device drivers on my computer
11) Now look for the manufacturer (LEFT PANE) Atheros Communications Inc.
12) NOT Atheros REPEAT NOT
13) Click Atheros Communications Inc.
14) Now under network adapter (RIGHT PANE) look for the EXACT following:

Belkin Wireless A/G Desktop Network Card

15) Click it then push NEXT
16) Click YES to the pop up
17) After it's done click CLOSE
18) BOOM! it's installed now click the network icon in the taskbar and enter your router's password
19) YOUR DONE YAY!!!"

Poster's name was Dec0594, just like to give credit to him as it's due.

There's other solutions on that page, depending on your chipset for the FSD7000 E. Seriously, it's such a hassel, I've been at these for days now.


Cheers guys, Nigel
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.