Change the default audio-CD (double click in This PC) player

Discussion in 'Windows 8 Help and Support' started by szczurcio, Mar 22, 2015.

  1. szczurcio

    szczurcio New Member

    Joined:
    Mar 22, 2015
    Messages:
    2
    Likes Received:
    0
    Okay, since there are many questions on this topic, none exactly the same as mine, I'd like to make myself perfectly clear.
    I know about Default Programs, and I know about Autoplay settings in the Control Panel.

    What I want to achieve is use Media Player Classic (comes with the K-Lite codec pack) to open my audio CDs (and DVDs) when I double click my drive in This PC. I was able to set MPC as the default for all media files it supports:

    [​IMG]

    I have also changed AutoPlay settings:

    [​IMG]


    And still, when I double click my CD/DVD drive (when an Audio CD is inserted) in This PC, it is the ugly face of WMP that I see:

    [​IMG]


    I can vaguely remember getting around this in Win7 a few years ago, using some sort of registry hack, but I can't seem to find it anywhere anymore.

    What can I do to force Windows to use the player I have chosen?
     
  2. szczurcio

    szczurcio New Member

    Joined:
    Mar 22, 2015
    Messages:
    2
    Likes Received:
    0
    Since for whatever reason I'm not allowed to edit my own post, I'm adding this information here.

    I've also tried changing MPC's settings, but to no avail:

    [​IMG]
     

Share This Page

Loading...