Dell Inspiron 14r Wifi detects networks but won't connect.

Discussion in 'Windows 7 Help and Support' started by jchaine13, Jul 21, 2011.

  1. jchaine13

    jchaine13 New Member

    Joined:
    Jul 21, 2011
    Messages:
    6
    Likes Received:
    0
    Hi,
    I've searched all over the internet, spent over an hour with dell support and found nothing. I'm visiting my parents for the summer and I brought my laptop with me and the wireless was working fine for the first month or so. One random day it stopped working and will not connect. I called dell support and for some reason it just started working when I was on the phone with him, but for the next couple of days it would connect for awhile then not connect 15 minutes later.
    It's not the router because it won't connect to other networks, the dell support guy says its not the hardware (everything in the device manager says its fine also), It works when the ethernet cable is plugged in, I installed all the latest drivers for the network adapter (Intel Wifi link 1000 BGN), I installed a registry fix program and for a little bit it was working with some networks, but only limited access. I've tried everything I can think of and I'm stumped So if anyone could help me that would be great.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    When somone says it was working, but now it isn't, the first question to ask is what might have changed? Did you add or remove any programs, especially anti-virus. Did Windows load a driver for your network adapter? Could your network be having problems, and did you reset the router and the modem?

    Do you know what you changed in the registry?

    If you click the wireless connection, are you showing your connection and what signal strength and what properties?

    You can open the Network and Sharing Center and obtain quite a bit of information. If it isn't connected, there should be no information in these pages, but if you click on the Connections and select details you will be given IP addresses you can check to see if they agree with your local network. Are you showing a Home Network, or Public Network?

    You can also click on "Change adapter settings" right click your wireless adapter, properties, then IPv4 and properties. If you do not have a reasonable Network address, you can enter one manually to check. It seems to me that every so often, if my network gets messed up, entering a temporary address will allow the device to work, then change it back to obtain address automatically, later.

    If you can't get any information and cannot get the problem corrected, I would probably uninstall the drivers for the device, and remove all versions, then uninstall the device. Let Windows find it again and see what happens.
     
  3. jchaine13

    jchaine13 New Member

    Joined:
    Jul 21, 2011
    Messages:
    6
    Likes Received:
    0
    Thanks for the response.
    The funny thing is I was watching netflix in my room on my laptop then closed my laptop went downstairs and put it on a bed, and it fell off, maybe 1-2 feet. From then on it hasn't worked correctly. There are no hardware errors thats why I think that it wasn't the problem.
    I don't know what I changed in the registry the program did it for me but I can always restore them. Yes the view networks show all the networks and signal strengths and properties. Itried the IPv4 thing and it still doesn't work.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Since you dropped it, possibly some hardware has lost its connections. Try opening the WiFi access and reset the card.

    If you changed the registry, restore it to check.

    Have you tried uninstalling the Wireless Adapter and letting Windows Reinstall it? There is always a chance, with the shock, something on the hard drive was corrupted. Perhaps even do a chkdsk to see if the hard drive is OK.
     
  5. jchaine13

    jchaine13 New Member

    Joined:
    Jul 21, 2011
    Messages:
    6
    Likes Received:
    0
    Okay so I did a system restore, and its now working (knock on wood), but i know for a fact that its not gonna work for long.

    There is one thing I did notice though that may have an importance. Always right before my internet starts working again, there's a message in my taskbar that says "bluetooth device not discoverable" then a little message or something like that, i'll get a screen shot next time it comes up. But this has to say something about whats not working, I'm just not smart enough to figure it out. Thank you for all your help by the way Saltgrass.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I don't know if the words are the same, but in the Bluetooth settings, there is a check box to make the Bluetooth discoverable by devices and some options for notifications about devices trying to discover it.

    I suppose if you are trying to add a device, some have to be set to be discovered by holding down a button on the device for a few seconds, such as a keyboard or mouse. On my devices, the led needs to be flashing red and green.

    Are you using any Bluetooth devices? If not, you might disable the Network Adapter.

    While your system is working, you might take a snipping tool picture of a command prompt window after you type ipconfig /all which you can compare when it stops (which hopefully it won't).
     
  7. jerrytheman

    jerrytheman New Member

    Joined:
    Jul 30, 2011
    Messages:
    2
    Likes Received:
    0
    I bought a Gateway EC1457U Notebook computer running Windows 7 with Atheros AR8131 PCI-E Gigabit Ethernet Controller and a Intel ® WiFi Link 1000 BGN. The wireless runs fine on the home network (Verizon) although it will periodically stop working. When I travel it’s hit or miss if it will work correctly but the range is always short to the router. Can't get on unless I can get 3 bars. For some reason, this machine will not connect to the wireless network at the job or to any network with less than three bars. The router at work is a public network with a Linksys (WRT54GS-V7) wireless-G 2.4 GHZ, 802.11g router. I did get it to work a couple of times for a few hours but then it would stop working. I can run a cable from the computer to the router and it will work but the wireless does not work. The computer recognizes that it as a Linksys router and reflects that it connected but there is a yellow sign on the five full bars next to the battery indicator. When I run Windows Diagnostics it says Windows cannot communicate with the device or resource. When I run other trouble shooting programs they reflect that my computer appears to be correctly configured but the device is not responding. I updated all the drivers from the device manager and updated the drivers from the built in Gateway updater that didn’t seem to work at all. I even disabled some programs in my efforts but nothing seemed to work.


    I got so frustrated that I purchased drivers for $29.00 which made the computer work temporally. The company that I purchased the drivers from kept updating all my drivers and eventually I was back to square one in that it wouldn’t work again. I finally got it to work correctly (I hope) after I did a clean install and I did all the updates from Microsoft. The version on my Intell WiFi link stated above is now version 13.5.0.6 dated 1/19/11. On occasion it will stop working but it will work when I open the network and sharing center. I then double click the red X between the home network or work network and the internet. It runs a check and then seems to work. If I do it any other way it won’t. Good luck. It's an Apple next time for me.
     

Share This Page

Loading...