disable secure boot

Peterr

Fantastic Member
If someone comes across a way to disable secure boot without clearing keys, or if I do, it would be nice to have it posted here. Not holding breath though.
My board is Asus TUF Plus z390 Gaming WIFI but a similar newer board might suffice.
I will ask elsewhere although we should not double post s I need advertising on this one. :)
 

Neemobeer

Windows Forum Team
Staff member
There isn't any reason not to clear the keys. There is a backup stored in the hardware, so once you clear them to disable secure boot you will see an option to install the default keys if you wish to re-enable secure boot.
 

Peterr

Fantastic Member
Yes I did do just that and it disabled the secure boot. However, Asus now has said the only time to clear the keys is if there is corruption. The builder has now said to enable CSM which in turn will disable secure boot. I tried but was presented with 4 choices I have yet to make note of. I'll try to give you those choices.I did not keep the changes, yet. I am not very skilled; this is pretty much over my head. I will ask the builder if I can bring it to him to see what he can do with it.
Thank you for your help.
 

Neemobeer

Windows Forum Team
Staff member
If the computer isn't having issues I would even mess with these settings. UEFI boot with secure boot is safer.
 

Peterr

Fantastic Member
This is getting a bit confusing for my level so I am bringing the pc to the builder next Wed.

I am trying to be able to boot off of a non compatible stick without clearing keys. I did clear keys and perform a boot off a non compatible stick successfully but it is not advisable.

The builder feels enabling CSM will disable secure boot but when I tried, I encountered a drop down of choices.

Please see the attachment for a view of the choices. I am waiting to see him.

I have been to the forum more than once but it seems geared to skilled users as the answers I got were not explanations but were more like clues that fly over the head of the average guy..
 

Attachments

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
When you enable CSM it's disable secure boot. Those option are all set correctly, so all thats now needed is to save and reboot too windows or the usb
 

Peterr

Fantastic Member
As you can see for the attachment there are drop downs . I do not know what to do with them b/c they too have choices .
If saving and exiting at this point was the answer that would be great but I am going to get it verified.
 

Attachments

Neemobeer

Windows Forum Team
Staff member
I would change Storage to UEFI and Legacy OPROM if you can but otherwise you can leave them as is
 

ussnorway

Windows Forum Team
Staff member
Premium Supporter
secure boot and csm are not the same thing on Asus boards "secure boot" normally lives in the [security tab]... try looking in advanced options

disable secure boot on Asus boards allows booting from nonstandard i.e, unrecognised drives such as any new usb stick... it doesn't do anything else and you can just leave it off all the time... of course some smart ass could then format your computer with a usb stick but thats the risk you take
 

Peterr

Fantastic Member
I started this thread so I thought it appropriate that I give what I think is the answer because I did lean on quite a few people and the thread was quite extensive. In order to disable boot on z 390 ASUS motherboard on my TUF Gaming Plus Wi-Fi set one has to go to firmware> Advanced. From advanced to secure boot and change secure boot mode from UEFI to other, exit and save changes. This disables secure boot. To enable it, the reverse is done. It can be verified through either system information or Security >Device. I hope this helps someone who follows me with this issue who wishes to use some Linux distros.
Unfortunately, ASUS, and the builder did not provide the correct fix nor did any forums I tried including the ASUS forum.
 
Top