Drive Active But Inaccessable

#1
I have a external Wester Digital drive plugged in to my PC via USB 2.0. Earlier today i did a clean OS install on my machine. Before the clean install, I was using the same windows 7 installation and the disc was accessible. Its listed in this picture as disk 6. Its marked as active. I tried changing the drive letter/path but i receive an error message. I receive the same error message if i try to reformat the drive. The error message tells me that a change cant be made because Disk Management is not refreshed. If i refresh disk management the status of the drive doesn't change. I have restarted Disk Management, restarted my PC and plugged the external into a few USB drives hoping for a different result.

The trick is, i need to recover the data on the drive. Any help that could be provided would be greatly appreciated.




Untitled.jpg
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
It appears you have been changing partition sizes or installing different OSes since you have those 9 MB unallocated partitions. Are you using a third party partitioning software? Is the Drive Hidden or have you tried to unhide it? Did you use any type of encryption software on the drive?
 


helpifIcan

Extraordinary Member
#3
Maybe a USB issue with the standard WIN7 driver, it may have worked fine before but it was a different driver version, go to USB maufactures site for a driver. The drive shows online not active in you pic. Do you have access to another PC so you can verify the drive and/or USB interface are OK? Can you remove the drive from the carrier and install direct to PC to get the information?
 


Joe S

Excellent Member
#4
Try looking on the WD forums. I think I've seem this posted before. Try on another PC if possible. Some times Test Disk TestDisk - CGSecurity will fix the partiton. If it's a drive that allows password protection removing from case may not work and will void warranty. One more thing is to try other USB ports use one in back without a hub if possible.
Joe
 


#5
Thank you for the replies everyone. I was able to access it and format it on another computer, but it still doesn't show on mine. both computers are running 64 bit windows 7
 


Joe S

Excellent Member
#6
Is this a powered or USB powered drive? WD USB powered can be cranky they make a power booster cable. Make sure it's plugged into a back port without a hub.
Joe
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.