(DRIVER) Missing driver after windows 7 install on gateway computer

Discussion in 'Windows 7 Software' started by kurts2, Oct 24, 2011.

  1. kurts2

    kurts2 New Member

    Joined:
    Oct 24, 2011
    Messages:
    4
    Likes Received:
    0
    Please help me! I have a Gateway MX6960 that I just put Windows 7 on. There is a missing driver on the Device Manager, but I don't know exactly what it is or where to get the driver. It is listed under "other devices" as "Mass Storage Controler". The only info I know are the hardware ids. They are :
    PCI\VEN_104C&DEV_803B&SUBSYS_0366107B&REV_00
    PCI\VEN_104C&DEV_803B&SUBSYS_0366107B
    PCI\VEN_104C&DEV_803B&CC_018000
    PCI\VEN_104C&DEV_803B&CC_0180

    All basic functions seem to be working on the computer. I have not tried to use the fire wire port, the card reader or the PCMIA slot. My guess is the PCMIA slot because I initially ran the windows update tool and it identified there wasn't a driver available. The reason I'm not sure if thats actually the issue is because there is a driver loaded under PCMIA devices! It may be there are suposed to be two and one is missing.

    Anyway to make things worse, I tried a auto detect program to ck my drivers. It did identify what I already knew, but also said there were 12 out of date drivers! One for the SATA controller, 4 system devices (PCI express root port 27D0 mobile intel 945GM/PM/GMS/940GML/943GML & intel 945GT express processor to DRAM controller 27A0), and 5 USB controllers (intel 82801G (ICH7 family) universal host controller 27C8).

    I went to Gatway and tried to install some of the drivers they listed for my laptop. They are of the auto install type and when I run the exe, windows 7 comes back saying this program is not supported. The drivers are newer and for VISTA 64 bit (I and running a 64 bit centrino duo processor).

    Is there a way to identify the hardware based on the ids listed above? If so, is there a place I can get an updated driver? Also the other drivers? Here is a link to the drivers listed on Gateway Gateway Support - Downloads & Support Documents

    Thanks in advance for any help in this matter,
    Kurt
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Looks like that might be your Texas Instruments Card Reader Driver 2.0.0.9 8/18/2010
    Good luck and welcome to the forums.
    Regards
    Randy
     
  3. kurts2

    kurts2 New Member

    Joined:
    Oct 24, 2011
    Messages:
    4
    Likes Received:
    0
    well...after my post I finished all the windows updates to include SP 1. After that I tried the driver install from Gateway and it worked fine! It installed successfully and the "other device" category disappeared. I may try to install the other drivers (to include the BIOS update) but I am a bit hesitant. I am of the mind of if it ain't broke, don't mess with it.

    Thanks for the welcome and reply Trouble.

    Kurt
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good work, glad to hear you were able to resolve your issue and thanks for posting back and updating your thread.
    Can't say as I blame you. I think I would prefer to enjoy a stable computer at least for a while before tempting fate.
    Thanks for joining our community and we hope to continue to see you around the forums.
    Good Luck
    Randy.
     

Share This Page

Loading...