dual boot (EFI) - windows 10 erases other entires

Adeom

New Member
#1
I'm trying to set up a dual boot of windows 10 and Fedora 27. On every boot to windows, the windows removes fedoras boot entry (the windows update blue screen shows up at the start of the boot if the entry exists).
Used the same dual boot setup over a month ago, worked fine through updates for over a year. Windows installation used same as before (i'm guessing this has something to do with recent updates).
Is there any workaround that persists through windows updates as well (preferably, but any solution works) ?
 


Neemobeer

Windows Forum Team
Staff member
#2
Updates shouldn't be an issue. Upgrades may re-install the bootloader at which point you'll need to boot into a live Linux usb chroot to your linux filesystem, re-install grub and then run update-grub.
 


Adeom

New Member
#3
This happens after every time i boot up to the windows, reinstalling grub and update-grub didn't help. Once i tried to boot into windows (from grub), on startup it erased the entry again.
 


Neemobeer

Windows Forum Team
Staff member
#4
After re-installing grub make sure there is an EFI entry by typing efibootmgr --verbose
 


Adeom

New Member
#5
Sorry for the late reply. Yes the EFI entry is created. Once i boot into windows, it gets erased. Both when booting directly into the windows 10 or when booting to it through grub. I know that this a common problem (or at the very least i found more then a few discusion and solutions, however not that many were recent), however it didn't happen to me before (a month ago, i've been running same dual boot as i am trying now for about a year, on the same device), so i am trying to figure out what happened and how to fix it long term (most solutions i found involved erasing and replacing windows files and need to be redone every update).
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top