DVD drive does not appear in WE

ruggb

Honorable Member
#1
When I open windows explorer I do not see the DVD drive or the "Removable Drive" associated with the card reader in the left folder pane. Only the HDDs show - (2 of them, one with 2 partitions)
If I go to Computer in the left pane then those will show in the right pane.
This is a brand new HP desktop so I haven't configured anything from its defaults.

How do I make it like every other computer I have seen.

W7 x64
 


zvit

Honorable Member
#2
Create a restore point first!!

1) Click the WINDOWS START BUTTON

2) Click over the Windows START BUTTON, there is the SEARCH engine.​
Click there and search for regedit​

3) Click regedit and the Registry Editor folder will open​

4) On the left menu, in order to make the folders drop down, click​
the following folders with an arrow as follows:
HKEY_LOCAL_MACHINE, then,​
SYSTEM, then,​
Control, then,​
Class, then look for {4D36E965-E325-11CE-BFC1-08002BE10318}​

5) On the right side of this folder, you will see some files (probably​
with a small "ab" on a little paper which is an icon). Look for​
LowerFilter and right-click it and delete it.

6) After deleting the LowerFilter file from your system,​
RESTART your computer.​
 


#3
If the DVD drive is not showing whatsoever, then Zvit's post is good to fix that.

There's an omission though (CurrentControlSet was left out):

This is the proper registry key to look for the filters. If there are any entries saying upperfilter or lowerfilter, delete them. Reboot.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

(The posting system automatically enters a space in Control above. Pay no attention to the space.)
 


ruggb

Honorable Member
#4
Thanx for such a quick response - awesome
BUT, I am a little confused....why would HP set it up to filter these devices.
I have never installed W7 and had filters by default.
What would be the point???

also what is that HKLM reference for??
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Some devices will not show in some locations if there is no media inserted.

Also, if you go to organize, folder options, view, there is an option to hide empty drives in the Computer folder you might see how it is set.
 


Last edited:

ruggb

Honorable Member
#6
Saltgrass
that may be the answer. It was not my system so I can't check right now but it makes more sense since that is a default I didn't think of and I don't think HP would have changed the default "filters".
Thanks
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.