Each USB drive appears 2 times in File Explorer: Top Level and under "This PC"

pstein

Extraordinary Member
Whenever I plugin an USB flash drive or USB hard disk then these devices are recognized by Win10 successfully.

But they appear always two times in File Explorer:

- As an entry on root level
- as an entry below "This PC"

The drive label is the same e.g. "USB Dive (F: )"

How can I disable this and let each USB storage appear only once (preferable below "This PC"?

Peter
 

Neemobeer

Windows Forum Team
Staff member
That's just normal behavior. If you don't want removable drives to show up in the navpane you can open the registry and go here

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\DelegateFolders\{F5FB2C77-0E2F-4A16-A381-3E560C68BC83}

Add a hyphen to the {F5FB2C77-0E2F-4A16-A381-3E560C68BC83} name

so -{F5FB2C77-0E2F-4A16-A381-3E560C68BC83} then restart explorer or the computer and they won't show up directly in the navpane.
 

pstein

Extraordinary Member
Thank you.
But your solution seems to delete BOTH entries.

I want to keep exactly one entry.
Is this possible?

Furthermore I prefer a solution by NOT fiddling directly in Registry. Is this possible?
 

Neemobeer

Windows Forum Team
Staff member
I don't believe so and there are no solutions that I'm aware of that don't require editing the registry directly.
 

Freya009

New Member
The feature you are talking about is the default feature of the file explorer.

There is no SAFE workaround to disable it. You’ll get two entries of connected storage space in the file explorer.
 
Top