File permissions changed by themselves?

Hi,

I went to made a new virtual box on a drive which was recently convertde to go from several partitions to just one, and although I can read files I cannot delete them or indeed write a new file to the drive. Not sure how this has come about. How can I get it back to normal? The username of the host is 'home' and the files are as per screenshot given read/write permission? I think I am pretty sure I did this in linux gparted, I remember writing a post on here complaining how it moved all the data which took hours rather than simply expand the partition to the start of the drive.
 

Attachments

  • Screenshot at 2020-09-12 12-02-29.png
    Screenshot at 2020-09-12 12-02-29.png
    23 KB · Views: 14
  • Screenshot at 2020-09-12 12-00-58.png
    Screenshot at 2020-09-12 12-00-58.png
    30.6 KB · Views: 14
I went into windows 10 to see if it had done anything and I can see four users on here when there should only be one user as myself, is this appropriate? I can see when i go to control panel> users there is only one user called House (me) and I am wondering if windows has seen linux and considered it to be desktop and thought it would give it restricted user privileges? I don't see how that is possible myself.
 

Attachments

  • Capturedesktop.PNG
    Capturedesktop.PNG
    10.2 KB · Views: 10
Well miraculously after just editing one file while in windows to change the "users desktop" to having all permisions linux can now write files and delete them. That's strange.
 

Neemobeer

Windows Forum Team
Staff member
Generally with Windows filesystems you have to add the mounting in Linux and explicitly grant the rw permissions.
 
Generally with Windows filesystems you have to add the mounting in Linux and explicitly grant the rw permissions.

Linux mounted that partition automatically, without issue, it was thus a surprise to find I had lost it. Since the weekend at which point it was fine, I now today have tried to use the drive and magically it has gone back to showing all the files and folders with padlocks...

So I opened up Disks and have this in the options field, however it seems the disk still cannot be written to by my standard user.

nosuid,nodev,nofail,x-gvfs-show,rw

I would have expected rw to grant me access to write to it. I think from what I can see it has become a 'groups' issue, I think my default user login is not granted root privileges?

I tried opening up Thunar in the terminal with root priviallges and it still could not write to disk. This makes no sense at all. Am I better off copying partition contents, then replacing the partition and then copying the contents back via linux?
 
Last edited:

Neemobeer

Windows Forum Team
Staff member
In my experience ntfs partitions never mount correctly and you have to edit the mount point. You may need to lookup how to do that with systemd or check out the ntfs-3g software
 
In my experience ntfs partitions never mount correctly and you have to edit the mount point. You may need to lookup how to do that with systemd or check out the ntfs-3g software

They have mounted correctly for years for me, I just added the following umask=000 and it still didnt work.
 
Check out ntfs-3g it has a user flag I believe will take care of the problem

What is this? What do you mean?

BTW I still don't understand why if I made this partition in linux in my home user login which is my standard login, why does this show me not having permision?
 

Attachments

  • Screenshot from 2020-09-17 19-07-54.png
    Screenshot from 2020-09-17 19-07-54.png
    46.2 KB · Views: 12

Neemobeer

Windows Forum Team
Staff member
ntfs-3g is a better filesystem driver for ntfs. As I stated ntfs tend not to mount correct (particularly for user access rw) If it's mounting read only then no one will have RW access to it.
 

Neemobeer

Windows Forum Team
Staff member
I haven't messed with systemd which is what Ubuntu uses now, you'll need to check their docs on where the mount targets are stored and edit them
 
I am confused as to what may have happened then, the only real difference to the setup that might have made a difference is using a partition editor that runs in windows recently however the change in partition in the drive in question was done using gparted. Given the hard drive i question which holds the partition of data I want both liux and windows to access, is there a easier and less problematic filesystem to use? its 500GB
 

Neemobeer

Windows Forum Team
Staff member
FAT32 usually works better and is better supported by Linux. You can make Windows recognized ext# file systems too.

And currently in the insider builds Windows will finally begin to natively recognize them
 
ok well I am extremely confused now, I just shrunk the ntfs partition, made a new fat32 partition in the space space on the hdd and now it lets me delete files in the origional ntfs partion that I could not delete files from before.. What on earth is going on on..
 
I can actually delete files now on the ntfs partition, the whole point of making the fat32 was because I cant have write access to the ntfs, why did changing the size of the partition give me the access I should have already had???
 
Top