Can't change file permissions as administrator

#1
I have an external hard drive I use to store movie files I have transcoded from DVD into .mp4 format. I used up most of the space on a 1 TB drive, so I am importing files to a 2 TB drive. there are nearly 200 files that did not successfully transfer- which I have determined to be caused by a lack of file permissions. It turns out that those files (somehow) ended up with special permissions rather than full read/write access. I don't know how this happened, but I am unable to change the setting.

opening the properties>security>advanced>change permissions dialogue shows the list of allowed users. SYSTEM has read/write access but administrator (me) has only "special" access. When I try to interact with the checkbox list to change permissions, all the options are greyed out and I cannot click any of them.

I came to this website since a google search of my problem turned up this old thread. I am having a similar problem, except that in that case, the user was able to interact with the check-boxes to add privileges, whereas I cannot.

It is possible the files are somehow corrupted, which would be rather disappointing as I would be left to re-transcode nearly 200 DVDs (a process that took me most of a summer). The lack of permissions (I think) is also causing me to be unable to share/stream these files on my local network and is the root of a lot of other nagging little problems for my home theater setup. Solving this would be a huge boon for me- I'd appreciate any help

thanks!!
 


Phred

Senior Member
#2
I have an external hard drive I use to store movie files I have transcoded from DVD into .mp4 format. I used up most of the space on a 1 TB drive, so I am importing files to a 2 TB drive. there are nearly 200 files that did not successfully transfer- which I have determined to be caused by a lack of file permissions. It turns out that those files (somehow) ended up with special permissions rather than full read/write access. I don't know how this happened, but I am unable to change the setting.
-snip-
How'd you go on this Graham? No-one seemed to be around with a response two years ago.
After a 32 to 64-bit upgrade and a file transfer migration similar to FAST, I ended up with permissions all over the place. Some 'DOS' instructions from the command line fixed the problem, but left the computer completely open. A riddle wrapped in a mystery.
Oh for some definition of default directory-tree permissions.
I'll go a-wandering...
 


Neemobeer

Windows Forum Team
Staff member
#3
Windows uses a DAC acl model. This means that any user with administrator group membership can take ownership of files. This is exactly what you will need to do in-order to change the "administrators" permissions.
  • Right-click, properties
  • Security tab
  • Advanced, click Change... Owner
  • Make yourself or the administrators group the owner and apply
  • Then you can grant yourself proper access
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.