Help, my persissions seem to change

AdamAntTex

New Member
Hey everyone, I am at my wits end. I have a Win 10 64 pro machine that if I run the machine for a while, and then go to install a program and try to delete the folder in Program Files so I can get a fresh install, the OS tells me that I don't have permission.

However, if I reboot the machine and try to delete the folder, it works. I see problems with running programs sometimes that I suspect that the permissions change and it can't write the configuration file (Solidworks seems to show this)

The weird thing is that I saw the same problem with Win7 Pro (hence the reason I updated to Win10)

Does anyone have any clues or suggestions to test things. I am going nuts trying to solve this. I know it sounds like it is something I installed, but it's a pretty straight forward install. Not too weird etc.

It behaves as if I have "admin" rights to start with but then the OS locks down to protect itself. It's just weird.......help..........

It doesn't only show up during installs.....that's just an example I have seen consistent.

Oh, I have 16 GB ram and shut down every night, so it's not a memory leak.
 


Neemobeer

Windows Forum Team
Staff member
If some process is accessing a resource in the folder you are trying to delete you won't be able to delete it until the handle(s) are released. You can use procexp to see open handles to a give resource.
 


AdamAntTex

New Member
Thanks for responding, I don't think that is the problem as I have seen the problem with deleting a folder out of program files that I knew nothing was open out of it. The SW problem is something I had them look at and they couldn't figure it out as well as they have never heard about the issue I was describing. It literally seemed to shut down the OS so I couldn't do anything. I did run Malwarebytes but I saw nothing there....
 


Neemobeer

Windows Forum Team
Staff member
It could easily be open by a process in the background you can't see.
 


AdamAntTex

New Member
I understand. But I looked and couldn't see anything using process explorer. I will double check but that still doesn't answer my Solidworks issue which should take care of itself as it appears that I am the only person they show having this issue. With that in mind, I have to go off the assumption that it is a "system" issue vs a single program. I find it hard to believe that more than one program could have an install/file access issue because of processes affiliated with different programs.

I guess my real question is "Is there anything people can think of that may cause this kind of weird behavior and I'll start looking there?"

I will look more at processes as well as try to get better details when and how this thing shows up.
 


Last edited:

Neemobeer

Windows Forum Team
Staff member
Generally the only two reasons you wouldn't be able to delete something would be permissions or a open handle. If you try and delete folder X, but there is a handle to X\Y\Z\blahblah.txt the entire delete operation would fail. It would be possible however not a common practice that a program could be altering the permissions on the fly, but that process would need to be running as a user that has rights to alter the permissions.
 


Neemobeer

Windows Forum Team
Staff member
You could tell if something was changing permissions.
  • Download procmon
  • In the filter add a Path filter to contain part or all of the path to the root of the folder in question
  • In filter add another filter to Operation IS SetSecurityFile
  • You should be able to see if something is setting permissions
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top