How to prevent access to folders in Windows 7?

Deathwing

Well-Known Member
#1
Hi, I have two users on my PC: Me (set as administrator) and a Guest account.

I would like to prevent users of the Guest account from accessing specific folders and their contents.

Can you please tell me how I would go about this?

Thank you!
 


#2
just right click on the folder and select the security tab deny access to the other users
 


Deathwing

Well-Known Member
#3
I unticked the box as instructed and right-clicked to bring up the Properties/Security tab. I have the following group or user names:

*Authenticated users
*SYSTEM
*Me
*Administrators
*Users

If I click Deny on permissions for "Users" I get a warning that if I am a member of two groups the "Deny" command will take precedence over the "Allow" permission. Then when I tried to access the folder from my "Me (Administrator)" account I am denied access.

I have Windows 7 Home Premium so does that mean there isn't any way to prevent Guests from accessing my folders?
 


Deathwing

Well-Known Member
#4
Awesome and many thanks Ben. It gave me a few errors for subfolders but as it worked for the main folder carrying them that should work absolutely fine. One related question if I may - is there a way to stop Guests from accessing Control Panel (I'm thinking of preventing them from being able to "show hidden files and folders" too if possible)?

Thank you
 


Deathwing

Well-Known Member
#5
Drew - is that something I can only do to user accounts other than Guest? With the "Guest" account I am only given the option to change the display picture or enable/disable the account.

Ben - I tried that command in Run but it does not locate a programme. I have Windows 7 Home Premium 64-bit, and my hard drive is set to C: if that makes any difference?
 


Deathwing

Well-Known Member
#6
Ben - same issue, "rsop.msc" is not found?
 


Deathwing

Well-Known Member
#7
Yes please if you can.

And many thanks for all of your help.
 


#8
i need help with this too anyone free......?inbox me.
 


Last edited:

davidhk129

Senior Member
#9
@ Tanvir Shahriar,
Right click at the folder in question > select Share with > select Nobody
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.