I set .txt files to open with the cmd program. I cant change the default program back

Discussion in 'Windows 7 Software' started by Keevu, Dec 28, 2009.

  1. Keevu

    Keevu New Member

    Joined:
    Dec 28, 2009
    Messages:
    4
    Likes Received:
    0
    I made a stupid mistake and changed the default program that runs .txt files to cmd. Now when I right click .txt files and try and change the default program back to notepad the "Opens With" option is not there anymore. I also tried going into Control panel/Programs/Make a file type always open with a specific program and setting the default program from there. But when I click on it and change it to notepad and click ok nothing happens and cmd is still the default program that opens .txt files.

    What should I do?
     
  2. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Is this Windows 7?

    I also, do not have that path or option???

    If it is Windows 7 unzip this file and run it. It will restore the association. Not for any other OS.

    Please make a backup of your registry before using it!!!!!
     
  3. Keevu

    Keevu New Member

    Joined:
    Dec 28, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks RAK that registry file fixed the problem. The way I set .txt files to open with cmd is, I right clicked a .txt file clicked the "Change Opens with:" button. I browsed to system32 and clicked cmd.exe. Then from there on every time I clicked on .txt files it just opened a cmd prompt. Then if I forgot to kill the task before I closed out of cmd it would make the file read only for some reason. So thank you for helping fix my problem.
     
  4. xixorro

    xixorro New Member

    Joined:
    Jan 17, 2010
    Messages:
    10
    Likes Received:
    0

    I guess I need tha file too RAK.where can i get it.please.and how do i make a backup os the registry
     

Share This Page

Loading...