Installing Windows 7 back from Linux

Aniket Dubey

New Member
I have a Lenovo Thinkpad Machine. It was originally shipped with Windows 7. Windows 7 was becoming laggy for me so I switched to Linux Ubuntu 16.10. Ubuntu was way faster and smoother than Windows 7, but the problem is that it doesn't have all the apps which I need to use to get my work done. So I decided to go back to Windows 7. So here's what I did. I had my Windows 7 ISO file with me. I formatted my pen drive (SanDisk 16gb) to NTFS. I burnt the iso file to my pen drive. I rebooted my PC and pressed F2. I selected USB drive and pressed enter. It just showed a black screen and booted back to Linux rather then Windows 7.
So what did I do wrong please tell me ASAP.
 

Akito

New Member
Please enter the BIOS when starting up your machine. Check all your settings and see if it has enabled "UEFI" and if "CSM" is enabled (maybe this entry isn't even there, at all). Also what exact model is your laptop and when did you buy it?
 

BIGBEARJEDI

Fantastic Member
Premium Supporter
Either you didn't create the USB W7 from a good ISO image, where exactly did you get it from? Or you didn't remember to change the Boot Preference Order in your Thinkpad's BIOS. This can usually be changed with <f9> or <f10> key on startup; download your Users Manual from Lenovo website for exactly which key. You can also try this with your USB drive on a different working computer that has any version of windows on it. If that other computer won't boot your USB drive, you probably didn't make it correctly, or have a corrupt ISO image file. Microsoft has scrubbed the Internet clean of most of those W7 ISO images, so a good one can be hard to find. Try using this link: Download Windows 7 Disc Images (ISO Files)
Using a link to an actual Microsoft download site usually produces the best result. After redoing your pen drive with the new ISO from my link; it should now work! :up:
Remember to change the Boot Preference Order on your Thinkpad so it can boot from the pen drive with W7 on it.

<<BIGBEARJEDI>>:nerdie:
 

Aniket Dubey

New Member
Please enter the BIOS when starting up your machine. Check all your settings and see if it has enabled "UEFI" and if "CSM" is enabled (maybe this entry isn't even there, at all). Also what exact model is your laptop and when did you buy it?
I dont have uefi . I only have BIOS .And my laptop is Thinkpad L420 and I bought it 5 years back.
 
Top