Issues with Caps Lock and localized characters in Windows store apps (Š, Č, etc.)

Discussion in 'Windows 10 Software' started by John33, Mar 19, 2017.

  1. John33

    John33 New Member

    Joined:
    Mar 19, 2017
    Messages:
    3
    Likes Received:
    0
    Hello,
    I run Windows 10 Home edition and have an issue with applications installed via Windows Store (OneNote, Viber, etc. but ONLY when they are a "Windows app". More info below) and "localized" capital letters. (I do not know how to call them, simply put: letters with special punctuation. Š, Č, Ř, etc. I guess Ü would be an issue as well, but I do not have a german keyboard layout so I cannot confirm that).

    Any letter that I write with my caps lock on and is a localized character (Š, Č, ...) is instead written as lowcase.

    For example, with Caps Lock on: řEšENí instead of ŘEŠENÍ.


    I can copy and paste text with capital letters just fine. I have also just realized that I can use shift to write those letters (by pressing ˇ and then S to get Š), but that is cumbersome.

    It only happens in a "Windows app". I am certain about that, because when I install standalone Viber via "old-school" installer, it works fine. But when I run Viber installed from Windows store, it suffers from this issue. I can run them side by side, both running at the same time, and the "old-school" is OK but the "native" one is broken.

    Any ideas how to solve this?

    I have found no online threads here or anywhere else mentioning this issue.

    I have a Dell Inspiron laptop and a logitech keyboard, if that is in any way relevant. (Keyboard should not matter, I have just tried the "Keyboard on screen" and the issue persists).

    With kind regards
    John
     
  2. BIGBEARJEDI

    BIGBEARJEDI Fantastic Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    2,312
    Likes Received:
    273
    Make sure that your Logitech keyboard is a wired and not a wireless keyboard (Bluetooth, IR, or Wi-Fi) first! If it does happen to be a wireless keyboard, find or purchase a wired keyboard and try it again. Wired keyboards are available at most computer stores and even Walmart or Radio Shack for $10-$20 US. I would also go into your Dell laptop BIOS (use <F2> key or similar) and disable the internal keyboard if it's not already disabled. This should fix the problem.:up:

    If the problem persists, there are a couple of things you can try. When you test your external keyboard on the laptop, use the CMD or POWERSHELL commands to get a DOS window and type your characters or test words in that window (Black & White) and see if the characters come out correctly. If they do, they most likely your wired external keyboard (USB) is working ok, but you have a problem with your W10 or your W10 language pack; it sounds like you might have installed the multi-language pack version of W10 instead of a single language pack. Did this Dell Inspiron come with W10 on it, or did you upgrade it from an earlier version of windows such as W7/W8x?? If so, did you do a W10 Clean Install after the original upgrade from the older version of Windows? If you did, where did you obtain the W10 bootable media ISO file or Disc from? It's possible that you used a copy from someone you borrowed it from, and it could be corrupted. Did this problem always occur since you bought the laptop? Or did it begin recently?

    Also, are you logged in to the Microsoft Store using a Microsoft Account Login, and NOT the Local W10 Login? If so, you can't properly download W10 apps from the Microsoft Store either free or fee-based unless you are logged on to W10 with a Microsoft Account Login. If you don't have one, you can create one while logged in with your Local W10 Account, give it a password and register it with your existing E-mail account (if not a Microsoft E-mail such as Hotmail, MSN, or Outlook.com), then switch over the Microsoft Account Login with your newly created credentials, and repeat your app downloads. That should fix it! :up:


    Let us know how you get on.
    Best,:encouragement:
    <<<<BIGBEARJEDI>>>>
     
  3. John33

    John33 New Member

    Joined:
    Mar 19, 2017
    Messages:
    3
    Likes Received:
    0
    Hello,
    thanks for your reply.

    I have upgraded from Win 8 to Win 10 without reinstalling. I have wanted to do it ever since I did the upgrade, but because I use the computer for work I didnt have time to do a full system reinstall ever since. So thanks for the info, it might be worth to wait until I do the full system reinstall and then I will see if the problem persists.

    So: when I will get to reinstalling my computer, what media do you suggest I should use? The oficially downloaded Microsoft ISO with single language? Did I understand that correctly?

    I could also try the BIOS settings you mentioned, might be worth a try.

    The characters work fine in every other program, even here on these forums I can easily use caps lock to write ŘEŠENÍ or anything simillar to that. That is why I assume that it is an issue with the Windows apps.

    To be honest, I have no idea how I am logged to the Microsoft store :) . I have checked right now and it is my "general" account (@live.com) that I use to connect to my One Note etc. online and also on my mobile (which is also a Windows phone, but I am not happy with the mobile OS, sadly enough :( ). So I should be able to buy applications and other stuff via this account. But all of the apps that I have issues with are free - Viber, One Note and even with the Feedback app that I used when I wrote a feedback to Microsoft (complaining about this issue), I was unable to use those characters. That was kinda funny :) .

    I will let you know how the BIOS solution worked, but I guess I will have to do the full system reinstall. I wanted to do it anyway after all, so it is not a really big deal.

    Thank you once more.
     
  4. BIGBEARJEDI

    BIGBEARJEDI Fantastic Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    2,312
    Likes Received:
    273
    You're welcome!;) You didn't tell us what that external keyboard was, whether it's wired or wireless? That will make a difference with what you are doing with troubleshooting and your BIOS settings. You really need to simplify things when troubleshooting, and if you have a wireless keyboard and or mouse combo, you are not doing this.:noway: You must really use a wired keyboard to track an issue like this down.

    Another thing you can try, is can you borrow a friend's W10 computer and login to the Windows Store and download the same apps and see whether they work correctly or not? Hopefully, this will tell you if the problem is in your computer only, rather than your Microsoft Account.

    And, you do have a Microsoft Account Login, :up:otherwise you cannot download any programs or apps from the Microsoft Store, either free or fee-based.

    Cheers!:D
    <<<BBJ>>>
     
  5. John33

    John33 New Member

    Joined:
    Mar 19, 2017
    Messages:
    3
    Likes Received:
    0
    Well..
    I have a wireless keyboard but I have already have a new keyboard on the way (a mechanical keyboard, looking forward to it ^_^ ) so I didnt mention it as the situation is about to change soon :-D .

    I have checked the BIOS settings and sadly this DELL laptop has no keyboard related settings in BIOS. Which is annoying as it starts with Num Lock turned off by default and maybe even those Store related issues might be connected to it. (I am fairly certain no such setting is in my BIOS - I have been fixing a friend's ACER laptor a week ago and I have seen both of those settings in his BIOS. Also... I am a software engineer, so I do know a thing or two about computers ( ;) ). But it's more about developing large-scale web applications than hardware settings in BIOS :D ).

    I am considering updating my BIOS and digging deeper into it, but only after I do a fresh reinstall of Windows 10 and after I get the new keyboard up and running.

    I will let you know if I make any progress or if I actually fix the issue somehow :) .

    Thank you for your time.
     

Share This Page

Loading...