Windows 7 Kernelbase.dll crash, when launching games (APPCRASH)

#1
Hi guys, i'm posting here my problem, because i think there's someone out there having the same issue as me. My problem is, i can't launch most of newest games at my new computer. I'm using Windows Seven, Ultimate 64 bit version.

I've read tons of topics about Appcrash problem (kernelbase.dll crashing), when running Windows 7 64bit. Here's my error message:


Nazwa zdarzenia problemu: APPCRASH
Nazwa aplikacji: AssassinsCreedIIGame.exe
Wersja aplikacji: 0.0.0.0
Sygnatura czasowa aplikacji: 4b6c634d
Nazwa modu
łu z błędem: KERNELBASE.dll
Wersja modułu z błędem: 6.1.7600.16385
Sygnatura czasowa modułu z błędem: 4a5bdbdf
Kod wyjątku: 406d1388
Przesunięcie wyjątku: 0000b727
Wersja systemu operacyjnego: 6.1.7600.2.0.0.256.1
Identyfikator ustawień regionalnych: 1045
Dodatkowe informacje 1: d519
Dodatkowe informacje 2: d51923b6b6eed548c2973b9d83cd4df2
Dodatkowe informacje 3: fb64
Dodatkowe informacje 4: fb6446c3f203379304c9302cebf08f94
It's in polish, tell me if u want it translated. Basically, crashed module is kernelbase.dll, application terminated Assasin's Creed 2, exception code (406d1388). I've tried AC2, Metro 2033, Call of Juarez. All of these don't work.

I've installed new video drivers from ATI site (10th february 2010). I've got DirectX 11, installed with Windows already. Do you know what might cause my problems? I've read something about installing old DirectX 9.0c, but isn't 11 supposed to have it already ? I mean previous versions of DirectX, up to 11 ? Anyway, i've installed DirectX 9.0c Runtime. Still, games don't work.

Also, some suggestions about Visual C++ Runtime Library. I've installed 2010 x64 version. No luck with it too.

The only games i've managed to install are CoD 4: MW, and MW2, also Perfect World (pretty old MMO).


My specs:
AMD Phenom x4 3.2GHz
4GB RAM 1600MHz
MSI Radeon HD5830

Tell me if u want any additional info.

Thanks in advance, and have a nice day ;)
 


Highwayman

Extraordinary Member
#2
Well in regards to drivers the newest is Catalyst 10.4 preview on the official AMD site, or theres the 10.3 whql either of which you should be using by now. Also try running installers and games in admin mode (right click launcher and select run as admin) to establish it isn't simply a permissions related issue.
 


Last edited:
#3
My current drivers version = 8.703.0.0
Date of release = 2010-02-10

I've tried installing game in XP Sp3 combatibility mode, and running it in this mode + admin rights. Doesn't work :( I guess it's some sort of wide known problem, related to DirectX, drivers, windows version or C++ library? Any sugestions?

Thanks for reply, sir.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.