Langue bar does not appear and/or shows wrong languages

Discussion in 'Windows 7 Help and Support' started by Exnihilo, May 29, 2010.

  1. Exnihilo

    Exnihilo New Member

    Joined:
    May 29, 2010
    Messages:
    6
    Likes Received:
    0
    Hi everyone,

    This is my first post here so I'm hoping that I'll do everything right! I've checked the forum (and google...) and this question doesn't seem to have been asked/answered. If it has, sorry for this.

    So, basically, I would like to have my language bar showing 2 languages FR/EN US, and I just cannot manage to do this. I'm under windows 7 64 bits. So here's more detailed description of my problem:

    When I have the 2 following languages: FR and EN UK, everything seems to work fine. When I then add EN US it shows the 3 choices. When I restart, however, it doesn't show EN US anymore even though the 3 languages still appear in control panel/modify input device or whatever the English name is.

    Likewise if I only have FR/EN US and I restart, the language bar doesn't show as the system seems to automatically remove EN US and language bar doesn't appear with only 1 language. But it still shows both FR and US EN in the control panel.

    I've tried to assign a shortcut (ctrl+0) to EN US but when I did this, it added Chinese instead (?!). The only "solution" I've found is to manually: remove EN US, apply, add EN US, apply. But it's just no fun at all doing this each time I boot my PC.

    I checked the task scheduler (as seen in answers to some similar questions) and the task MsCftMonitor is running. I stopped/run it and the language bar still didn't show up when I only had 2 languages (FR/US EN).

    I would really appreciate any help regarding this issue.

    PS: I came across this post (that I'll show in a reply to my own thread since I can't here)
     
  2. Exnihilo

    Exnihilo New Member

    Joined:
    May 29, 2010
    Messages:
    6
    Likes Received:
    0
  3. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Have you tried this.
    In the Control panel, (icon view) open Region and language.
    Select "Change Keyboards"
    Select " Language Bar"
    "Show additional Language ba icons in the taskbar" and/or
    Show text labels in the Labguage bar"
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321

    Regional and Language Settings -> Text Services and Input Languages -> Settings tab -> Default input language -> set default language (that you want to appear on system start).
     
  5. Exnihilo

    Exnihilo New Member

    Joined:
    May 29, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks for both your answers.

    To Rak, yes I've tried this, but the problem is that US EN does not appear in the language bar even though it's added as keyboard.

    To Cybercore, I've tried this as well but then it switches by keyboard from French layout to US English, which I don't want. I just want to have it as a choice (because it somehow makes hotkeys work in a game).

    I'm perfectly able to add it but it disappears each time I restart Windows.

    Thanks for your time!
     

Share This Page

Loading...