"Limited Access" & "Unidentified Network" When connecting to Router via WIFI

Discussion in 'Windows 7 Networking' started by Brett Davey, Aug 9, 2010.

  1. Brett Davey

    Brett Davey New Member

    Joined:
    Aug 9, 2010
    Messages:
    4
    Likes Received:
    0
    Hi,

    The title says it all really. I attempt to connect to my router via wifi and after about 20 seconds I get "limited access" and it also says "unidentified network". I searched google and gone through everything but can't find a solution that works.

    I am using a Compaq Presario Laptop (if that matters). I have an excellent signal to my router and for now I have disabled any security protection (I heard WIN7 can have problems with security).

    Any ideas? Thanks!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Ususally the unidentified network thing, is a product of not receiving the proper IP addressing information, from what ever is providing DHCP on your network (usually your wireless router)
    Launch a command prompt by typing cmd into the search box and hitting the enter key.
    type ipconfig /all at the prompt
    examine the ip address information assigned to your wireless card ... my guess is that it's probably an APIPA address with a missing default gateway.
    You can over come this, by manually assigning static values for the IPv4 address, gateway and dns for the problem adapter.
    You may also want to try disabling IPv6 to see if that helps at all, sometimes it does, more often it dosen't.
    You may also want to experiment with different encryption levels on the router itself, if you're using WEP maybe try WPA or WPA2.
    Keep us posted and if you need any further help just let us know.
     
  3. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Do you have your Router's "Network Name" (SSID) and "Password" (PSK) set correctly in your laptop's wireless settings?

    If you haven't yet... get into the Router's setup utility and set up an SSID and PSK in the router. Set security to WPA and AES (that will make sense when you see the router's setup secreens).

    Then on your laptop set your default protocal to WPA and AES, just like in the router. Now look for your SSID to show up on your available systems list, click connect and enter your password... you should be in.
     
  4. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    FWIW... I've had problems with WPA2 on Win7 machines... This is a supposedly hardware encryption but many wireless cards handle it through software emulation. Since it's very time sensitive it quite often fails on Win7.

    WEP works but is too easily penetrated.
    That leaves WPA....

    Hope this helps.
     
  5. Brett Davey

    Brett Davey New Member

    Joined:
    Aug 9, 2010
    Messages:
    4
    Likes Received:
    0
    I disabled the password because like I said I've heard it can conflict with windows 7. Anyway, when I type ipconfig in CMD I get an ipaddress but no "gateway" other than "0.0.0.0" etc.
     
  6. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    The gateway and DNS should be the IP of your router...
    Maybe you should check what that's set to.

    Also disabling PSK on a wireless is a VERY bad idea as it's simply an invitation for others to use your internet... which may account for some of the slowness you are experiencing.

    From where you are now, I'd say your best bet is to do a complete setup on your router... SSID, PSK, Internet, etc. then come back to your computer and redo the wireless setup from scratch. Make sure everything is correctly set up as we've described then see what you get.
     
  7. shall

    shall New Member

    Joined:
    Jan 30, 2014
    Messages:
    12
    Likes Received:
    0
    I have this problem, and although I don't understand everything above, it sounds like this might solve it.I am failing to connect to my normal 2 wifi networks after unsucessfully connecting to a friend's wifi. under wireless lan adapter i have default gateway....: [none]. I have tried changing ipv4 to automatic but I get message saying in need to enable wireless adapter card. if I need to give other info let me know, thanks.
     
  8. shall

    shall New Member

    Joined:
    Jan 30, 2014
    Messages:
    12
    Likes Received:
    0
    here is my ipconfig attached:
     

    Attached Files:

  9. shall

    shall New Member

    Joined:
    Jan 30, 2014
    Messages:
    12
    Likes Received:
    0
    I think somehow my laptop does not read the IP of the wifi, can anyone tell mme how to fix this?
     
  10. shall

    shall New Member

    Joined:
    Jan 30, 2014
    Messages:
    12
    Likes Received:
    0
    er, thanks for your help
     
  11. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    You have tacked your problem on the end of a thread which is three years old. It is much more likely to be read and responded to you if you created a new thread of your own.
     
  12. shall

    shall New Member

    Joined:
    Jan 30, 2014
    Messages:
    12
    Likes Received:
    0
    okay sorry I thought if i had the same problem I should stay here. I'll write a new thread.
     

Share This Page

Loading...