Making Files that are Opening Take Focus

Discussion in 'Windows 7 Help and Support' started by VicVicVic, Nov 9, 2009.

  1. VicVicVic

    VicVicVic Senior Member

    Joined:
    Sep 21, 2009
    Messages:
    66
    Likes Received:
    4
    Hello, I hope you are doing well.

    When I open some types of files, such as image files (e.g. jpeg, gif), they appear in the taskbar and blinks there, telling me that it is open. However, I would like all files that I open to take focus and show up right away, instead of having me click on the item in the taskbar to view it. How do I go about doing this?

    This seems like a very easy task, but I have not been able to find a way to achieve this. Thanks.
     
  2. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    It looks like you may not have a graphics program installed and/or have lost the associate for the built in "paint"
    In the "Start" open "Default programs".
    Select "Set your dfault program"
    Click Paint and, over on the right, select "set this program as default"

    Now try again and see if the problem is solved, or post back.
     
  3. VicVicVic

    VicVicVic Senior Member

    Joined:
    Sep 21, 2009
    Messages:
    66
    Likes Received:
    4
    I had no idea that it was an issue related to Default Programs - thank you very much for bringing that to my attention. I just tried this, but received mixed results.

    As per your recommendation, I tried setting Paint as the default program for all image files (previously, only three types of files had Paint as their default). This worked perfectly, so that's the good news.

    However, I would like Windows Photo Viewer to be the default program for viewing image files like jpeg. I then tried setting Windows Photo Viewer as the default program for image files, but then the same issue returned: any image files that I open would not show up right away once again.

    Any thoughts on this? Thanks.
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    I must say, Vic, with humility, that it's got me beat. My first suggestion was a one off. I am unable to simulate what you are experiencing.

    I am now thinking in different paths. Perhaps a graphic or memory related proble. Anyway, with this post I am bumping the thread, so maybe someone else will pop in with the solution.
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Have you tried putting any new pictures in a different folder and open them? Where do you have the UAC set?
     
  6. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Windows Photo viewer is hard coded into Windows Explorer. If you open Windows explorer and right click a picture,and then "Open with", it will open in the viewer. But it seems there is no way to make it a standalone program, as it has no .exe

    I think you will have to settle for another graphic/photo progam to achieve what you want. Best if you use the Photo gallery as the default.
     
  7. VicVicVic

    VicVicVic Senior Member

    Joined:
    Sep 21, 2009
    Messages:
    66
    Likes Received:
    4
    I did try that, but experienced the same results. My UAC is set to the lowest possible setting: Never Notify. I got sick of all these pop-up messages; for the most part, I know what I am doing on the computer and am not really worried about doing something wrong that will mess up the system.

    With further testing, I realized that after I right-click on an image file in a specific folder and choose "Open With," then "Windows Photo Viewer," all the images in that folder will open with Windows Photo Viewer and take focus from then on. However, all other images outside that folder and in that folder's subfolders are still stubborn and won't do that. This seemed strange, but it may be helpful somehow.

    Yeah, I'm considering getting IfranView or something (I used it for Windows XP, but I really didn't like the file icon, if you've seen it before).
     
    #7 VicVicVic, Nov 9, 2009
    Last edited: Nov 9, 2009
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Turn the UAC back up and try again. The reason I suggest this is because the blinking Icon may be a security warning.

    You might also check the properties on the different folders as far as security and see if they are the same.
     
  9. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    I think, reading through, Vic, that you have achieved all that is available. As I said, you will not be able to use Photo viewer as a stand alone viewer. The reason for your Right click - open with discrepancy, ( However, all other images outside that folder and in that folder's subfolders) is because this only associates one particular handle, for example .jpg.
    But why don't you like Photo gallery for these puposes. You can make this the default in the same way as suggested, and it should then open your pictures as desired.
     
  10. VicVicVic

    VicVicVic Senior Member

    Joined:
    Sep 21, 2009
    Messages:
    66
    Likes Received:
    4
    Thanks for all the help, Rak. Here's a question I should have asked earlier (I thought I did, but I apparently did not): What is Photo Gallery and how do I set it as my default program? I cannot find anything called Photo Gallery, it seems.
     
  11. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Oh. I have it installed by default in Windows 7 Ultimate RTM/Retail. I work through Technet so it may be a one off. Anyway, there is a more superior progarm available. Windows Live. It is a suite of prgrams, mostly useful. You can select, in the install, only those options you feel a need for. I have attached it to save you the bother of searching/downloading again. I highly reccomend the Photo gallery in the suite.
     
    #11 RAK, Nov 10, 2009
    Last edited: Dec 19, 2009
  12. VicVicVic

    VicVicVic Senior Member

    Joined:
    Sep 21, 2009
    Messages:
    66
    Likes Received:
    4
    Thanks for the Windows Live thing. I remember reading about it months ago, but had completely forgotten about it.

    So I installed Photo Gallery and think that it's a pretty nifty program, especially as a free one from Microsoft. Unfortunately, I ran into a problem. After setting the Default Program and giving Photo Gallery all of its defaults (at this point, Photo Viewer has 0 defaults and Paint has 3 defaults), I try opening jpeg and other image files. Guess what? They open with Photo Gallery, but Photo Gallery is blinking in the taskbar and does not come up automatically when image files are opened.

    I am surprised at the hassle we have to go through to achieve something this minor. I'm still going to work on the problem, but if you've had enough, feel free to just stop trying, as I feel bad that you've spent a good part of today helping me already. Thank you very much.
     
    #12 VicVicVic, Nov 10, 2009
    Last edited: Nov 11, 2009
  13. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    This is my hobby, Vic, so I have never had enough. But in this case, I am totally out of ideas. Sorry. By the way, how much ram have you installed?
     

Share This Page

Loading...