Monitor will Sleep, Computer Won't

Discussion in 'Windows 7 Help and Support' started by jharkema, May 1, 2009.

  1. jharkema

    jharkema New Member

    Joined:
    May 1, 2009
    Messages:
    6
    Likes Received:
    0
    Hey all!

    So I seem to be having a rather weird problem. My computer's screensaver will engage, the monitor will auto-sleep, but when the computer goes to sleep it immediatly wakes up. It goes to sleep for about 3 seconds, then wakes up. I have upgraded all of my device drivers (esp. Input devices), and it still will not goto sleep.

    Anyone have any advice?

    Thanks!
     
  2. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    Please take a look in Control Panel> Power Options ( in All Control panel items view of Control Panel) or
    Control Panel > Hardware and Sound >Power Options in Category view of Control Panel
    and Click Choose when to turn off the display from the left pane and set the time to Turn off display and Put the computer to sleep boxwith their respective down arrowheads to make the choice you wantandclickthe Save changes button before closing the CP
     
  3. jharkema

    jharkema New Member

    Joined:
    May 1, 2009
    Messages:
    6
    Likes Received:
    0
    Hey! Thanks for your prompt response!

    Both of these setting are set correctly, the monitor is set to 10 minutes, and the computer is set to 30 minutes.

    When the computer trys to goto sleep it just wakes itself up immediatly.
     
  4. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    I am wondering if the Monitor itself has a driver that conflicts with Display driver . To dig deeper into the issue, can you provide your Compuer SPECs ( if Brand name PC) or Motherboard Specs and Monitor make and Model please. Are there are any BIOS Setup Power Options that override the Operating System Power Options?

    Additional things to look: USB controllers might also cause this problem if Allow this device to wake the computer check box is selected thru' Device Manager > Universal Serial BUS Controllers> Properties> Power Management tab
     
    #4 cmn, May 1, 2009
    Last edited: May 1, 2009
  5. jharkema

    jharkema New Member

    Joined:
    May 1, 2009
    Messages:
    6
    Likes Received:
    0
    Okay, my computer is a standard make - up Dell XPS 710 desktop. The only hardware change I made was to add 2G of RAM in 2 x 1 G DDR2 sticks.

    I have installed all the most current drivers for my Monitor (Dell 2007WFP Analog), but the new nVidia driver released yesterday hung on install so I'm still running WDDM v 1.0 on my 7950 GX2.

    I have a Masters in Computer Science but for some reason this is totally stumping me. I will check the BIOS to make sure that somehow it's not overriding the OS.

    Thanks again!
     
  6. gregrocker

    gregrocker New Member

    Joined:
    Feb 8, 2009
    Messages:
    70
    Likes Received:
    0
    Whenever I have this issue, I find that Google contains all the clues needed to solve it. It is a rather long checklist (unsigned drivers check, video driver rollback/update, insomnia apps, wake disallows, are just a few). I just got off the phone with my Uncle troubleshooting hibernate by setting Power Option timeouts all down to 1-2 mins and started unplugging successive USBs, when I suddenly notice he has his radio on in the background. Turned it off and it worked. So it goes.

    Just be glad it isn't something like chronic restart-on-shutdown because that has proven unfixable here except to hibernate instead, and I'm told I should be thankful it will even hibernate.
     
    #6 gregrocker, May 1, 2009
    Last edited: May 1, 2009
  7. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    It's always good to know the background of the person asking the question so that the reply won't be too elimentary although those less computer savvy might also benefit from forums exchanges :)

    I was suggesting in the additional information I posted, to check the Power Options of Special USB Keyboards with "sleep buttons" and USB Mouse and sometimes these options in DM might be conflicting and overriding the CP settings one could make thru CP>Power Options. It was just a gentle reminder if you know what I meant :)
     
  8. dar25

    dar25 New Member

    Joined:
    May 12, 2009
    Messages:
    4
    Likes Received:
    0
    I've got exact same issue. For whatever reason my PC auto-wakes up a few seconds after it's put into S1 sleep.

    I've tried the usual things, like makign sure my usb devices dont have right to wake up pc, removed wake up timers in the power settings, made sure that wake on Lan and Wake on PCI are turned off in the bios... No luck.

    I am wondering if the fact that i have nvidia performance tools (v6.03) installed on this machine to control video cards fans that may be causing the issue, but other than that it's a pretty standard Windows7 RC1 install.

    Any suggestions?
     
  9. dar25

    dar25 New Member

    Joined:
    May 12, 2009
    Messages:
    4
    Likes Received:
    0
    Hi All,

    Found solution to this issue elsewhere. Turns out, unlike Vista, Win7 gives the network adapters ability to wake PC up from sleep by default. This is what usually causes the system to come back from sleep unexpectedly.

    If you go to device manager and see properties for your network adapter, in one of the tap you will see the option to wake up from sleep checked. Turn that off (as well as the mouse if you havent already) to make sure Sleepy Win7 will stay asleep. :)

    you can also use:
    powercfg -devicequery wake_armed
    from command prompt to check which components can wake PC from sleep.

    Original credit for posting the solution goes to Carlos at velocityreviews.com:
    Sleep problem in Win 7 - SOLVED
     
  10. Theresa_N

    Theresa_N New Member

    Joined:
    Jun 7, 2009
    Messages:
    12
    Likes Received:
    0
    I have tried everything I can find

    My computer will not go into sleep mode. It starts to and then returns to the desktop. I have googled the problem and searched all the Windows 7 forums I could find. I have loaded new device drivers, set devices not to wake up the system and tried every setting in the bios that is relevant. I have a Gigabyte i7 motherboard with two wd hard drives, and 64 bit Windows 7 RC installed. My HTPC case has a remote controlled on/off button and cannot be turned off otherwise except by an internal switch or the switch on the back of the power supply. It is very difficult to reach in a desk where it sits on a shelf. So simply turning it on and off routinely would require me to pull it out to reach the switch.
    Please help. Please do not suggest things that have already been suggested in this forum as I have already done a thorough search.
    Please help!
    Theresa
     
  11. Theresa_N

    Theresa_N New Member

    Joined:
    Jun 7, 2009
    Messages:
    12
    Likes Received:
    0
    Got sleep to work

    I couldn't get Win 7 x64 to sleep. I worked on it for several days. I tried everything suggested on line. None of it worked. Finally I swapped my cordless keyboard and mouse with corded ones and it worked! MS needs to fix this.
    Theresa
     
  12. CavsFan

    CavsFan New Member

    Joined:
    May 20, 2009
    Messages:
    2
    Likes Received:
    0
    This is what solved my problem! I didn't know that in Device Manager under Network Adapter there would be a place for the computer to be woke up. My computer had been going to sleep, but would not wake up without turning it off and back on and it would display "Resuming Windows".
    But thanks Dar25 for the post and for not taking credit for it!
    I didn't have to read past the first page!
     
  13. nehoma

    nehoma Honorable Member

    Joined:
    May 8, 2009
    Messages:
    491
    Likes Received:
    7
    Great stuff this. I had the same problem and it has cured it but why is none of this ever in the books they write as Windows Manuals. I have never seen in a manual a list of commands to use in CMD. Likewise I nevfer knew about, AHCI mode of operating SATA hard drives fom a windows manual but from my neww motherboard handbook and google.:rolleyes:
     
  14. Harris2508

    Harris2508 Honorable Member

    Joined:
    Jun 2, 2009
    Messages:
    26
    Likes Received:
    0
    I confess that I haven't read all of the messages on this thread, however, I have found that the most common cause of the issue described above is not clearing the check in the Mouse > Hardware > Properies > Power Management section that "Allow this device to wake the computer". An optical mouse will send small signals to the PC that will prevent the OS from putting the PC to sleep.

    --Bob
     
  15. drtobin

    drtobin New Member

    Joined:
    Nov 26, 2009
    Messages:
    2
    Likes Received:
    0
    Weird solution

    I also had the issues. I solved the problem by doing the following.


    Screen saver: 10 minutes
    Monitor off: Never
    Computer Sleep: 1 minute
    Save and wait 1 minute.

    My computer went to sleep after the 1 minute.

    I then reset all the times (screen saver 10 minutes, monitor off 20 minutes, computer 1 hr) and everything is working fine.

    I have no idea why this worked but for me at least it did.
     
  16. rcdantes

    rcdantes New Member

    Joined:
    Dec 4, 2009
    Messages:
    2
    Likes Received:
    0
    I have the same problem as the thread states, Monitor will turn off but system won’t go to sleep, even when I press the sleep button. The screen will turn off but my HDD light will still keep on processing, the fans are still on, even after 30 minutes of pressing the button. I have checked the binding to that button in the power option and it's in sleep, in both battery and plugged in besides I don’t see any option in there to just turn off monitor when the button is pressed. I even tried the sleep button under the windows start menu, still the same result screen dies laptop still on.

    This was not a problem before, when win 7 was freshly installed 2 months ago, sleep process would work. Sleep would kick in when I leave it for 30 min which is normal since I set it to go to sleep that way, but lately I have noticed that it does not go to sleep anymore, even after leaving the computer for 4 hours or pressing the sleep button. The screen is dead but the computer is very much alive and buzzing. I could not tell if this just happened recently of it may have been this way for quite some time, since I usually shutdown my laptop.
    I have already checked network adapters & mouse, to see if it will wake the computer and it has no check mark on that option. I also sifted the power option and its advanced power options nothing out of the ordinary. I have already installed a new video card driver still dint resolve the problem.

    I have a Windows 7 Pro running on ASUS n80vn laptop. No other major changes since the clean install of windows 7 and drivers. Got my windows 7 pro from MSDN, this is not just release candidate it’s the released version for MSDN subscriber and is good as retail.

    I have a degree in Computer Network Engineering

    I know it’s quite lengthy I just want to cover all the bases to limit the back and forth of question and answer.

    *on additional note it would enter sleep if it's just on battery, but plugged in still wont sleep.
     
    #16 rcdantes, Dec 4, 2009
    Last edited: Dec 4, 2009
  17. Deviega

    Deviega New Member

    Joined:
    Aug 3, 2010
    Messages:
    2
    Likes Received:
    0
    Thank you dar25, You have the right solution I have being looking for about a year now
     
  18. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Is your computer by chance connected to a "Work Network" (Workgroups)?

    One of the most common causes of computer insomnia is the "Computer Browser" service. What happens is your computers will decide amongst themselves --they actually hold a "Browser Election"-- that one machine is the Master Browser. This is usually the machine with the best network attributes, fastest cpu etc. It then holds all share lists, for the entire network. Once a machine is elected as a master browser it won't go to sleep until all other machines on that Workgroup are asleep. If it does go to sleep it gets a bunch of objections from other machines, waking it back up.

    If watch your router, you will see a short burst of activity, just as it goes down...

    If you have wake on lan enabled, it's going to wake back up because of the "Browser Election" it just forced.

    The fix --if indeed this is the case-- is pretty simple. If you have a machine designated as a server (I use my HTPC) you can disable the Computer Browser service in all but that one machine. Then your other computers should sleep normally and still wake up to handle network traffic... A LAN only needs one Master Browser per Workgroup.
     
    #18 CommonTater, Aug 3, 2010
    Last edited: Aug 3, 2010
  19. cusco

    cusco New Member

    Joined:
    Sep 8, 2010
    Messages:
    6
    Likes Received:
    0
    Hi,

    Thanks for the tips, but it is not working for me. Everytime I tell teh computer to sleep (by keypress, cli, or clicking in the start menu), it will only put the screen black, but continue working.

    If I press the little switch that counts as lid closed, as soon as I release it, login screen is right there, too fast.

    And after I done that a few times:

    C:\Users\Tiago>powercfg -lastwake
    Wake History Count - 0

    C:\Users\Tiago>

    -

    Can anyone help me???
     
  20. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372

    Type msinfo32 in the start menu then press enter. File | save on the opened screen. Then zip the saved .nfo file. Attach the zip to a post and I can have a look at your current system to see what might be causing issues for you.
     

Share This Page

Loading...