NAS not present i Network list

#1
Relevant network units: Two PCs (W10) and one NAS (WD MyCloud). All units belong to the same workgroup. Both PCs are wirelessly connected. NAS cable connection to router. Network classified as private in PCs (with Norton). Resources on the NAS can be accessed from both PCs, ie the network adress of the NAS can be used in both. It is expected that the network listings of each PC (File Explorer, Network entry or network list of the mapping process) should show both PCs and the NAS.
This happens in ONE of the PCs but the other one lacks the NAS entry. Inactivation of Norton or restart of the "faulty" PC and/or the NAS makes no difference. What should I look for?
 


bochane

Honorable Member
#2
I don't know the answer, but to get a better idea of what is going on next questions:
- has the NAS a dedicated fixed IP address in your network?
- can you make a permanent network connection Z: to some location on the NAS?
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#3
Hi,
Well there are several things that could cause this problem such as:
1.) Virus/malware infection on the 2nd PC that can't access the NAS folder structure
2.) Interference from your AV program, Norton, especially if you have Norton360 which has known network issues, including difficulty using remote login software such as Logmein and GoToMyPC. Which Norton version EXACTLY are you running, and which Norton Product do you have?
3.) Faulty wireless adapter in your 2nd PC
4.) Failed Wi-Fi network drivers on the 2nd PC
5.) Corrupted, deleted, or missing routing tables in your Wi-Fi router
6.) Corrupted W10 registry files in your Hive on 2nd PC

All of these take time and some good troubleshooting techniques to figure out. Until you can provide us with your Norton product/version, I can't be more specific. But, Norton and most other AVs have a plethora of settings in both their various security settings for things like E-mail, Blacklists/Whitelists in the Firewall, App filtering, Packet-filtering selection, etc. So, it's best to use your Norton to scan for any viruses found on that 2nd PC first, and remove all found. Power-cycle that PC (shut it down via power-off) and reboot; retest your NAS folder access list via File Explorer. If you can access your NAS device and see the same folder list you do from your 1st PC; you had a virus on the 2nd PC and removed it (or quarantined it), and fixed your problem! :up:

Generally, speaking network problems are rarely solved this easily (unless your a networking genius like me!). But, it happens sometimes if you get lucky. If your problem persists, I can suggest some other things to try first; as the list of things to try can be quite long; problably a couple of dozen.
1.) Since certain Norton products as 360 can hang up your network access, the easiest thing to try is to temporarily disable your Norton AV or IS (Internet Security suite) on that 2nd PC. Power-cycle the 2nd PC, and restest. Remember to wait for 30 min. after the reboot (will explain that later), refresh your File Explorer and check your NAS again. If it's fixed, then your Norton product is preventing access to the NAS, most likely with certain security settings as I mentioned above! :eek: Clearly, the Norton on your 2nd PC is somehow different than the one you are using on the 1st PC. Make sure that you are using the same Norton product on the 2nd PC as the 1st PC. For example, if you have Norton AV only on the 1st PC but Norton360 on the 2nd PC; you should remove the 360 from the 2nd PC and replace it (temporarily at least) with Norton AV to make it look just like your 1st PC which is working ok. This is just one of many scenarios which could solve your problem also. We see this one a lot.
2.) You can run the Norton repair, either the one built into their product, or download the repair tool from the Norton website for free. This will often fix problems. If it does, your Norton product was failing and has been repaired. You're then set to go!:up:
3.) If the problem persists, even with your Norton product temporarily disabled, the problem lies elsewhere further down the list of things I listed above that can cause this type of problem. See #4.
4.) The next thing to try that's quite easy, is to run an Ethernet cable to that 2nd PC directly from your wireless router and disable the Wi-Fi connection on that device. If it's a desktop PC you may have to go into the BIOS at startup to do this. You can google this for video on YouTube to show you how to do it. If it's a modern laptop (>2009), most of them will auto-switch from Wi-Fi to Wired (Ethernet) connection automatically and you don't have to do anything. Just fire up your File Explorer and check your NAS folders. If they are now there, the problem is in your Wi-Fi on that 2nd PC; either the WLAN chip/card may be failing or has failed and that's why it's not properly accessing your NAS device! :waah: Once you know that, you can replace the device if it's removable, such as a USB plug-in Wi-Fi adapter such as Cisco/Linksys, Netgear, or Belkin. They are relatively inexpensive; $40-$60 US. Replacing that device should take care of your problem and you are good to go!:up: If it's a laptop, and you are using an internal WLAN chip, and it still doesn't work, I'd suggest you visit the support website for your laptop (Dell, HP, Acer, Toshiba) and update your Wi-Fi driver. Sometimes, the weekly W10 push updates from Microsoft will insert a new driver from Microsoft that is busted, and your Wi-Fi on the PC that received that update will fail partially (as with your NAS) or fully--no Internet whatsoever. In that case, you can buy one of the USB plug-in Wi-Fi adapters, and disable your internal WLAN chip on the laptop and just run the USB adapter. This is much cheaper than replacing the WLAN chip inside of the laptop, as it's labor intensive and can cost from $110-$180 or more.
5.) If neither #4 works nor does switching out the Wi-Fi adapter card/chip, it could be a security setting or filtering/forwarding option inside of your Wi-Fi router causing this problem. Many customers had a Tech or a friend somewhere along the line setup a Mac-address restriction on the router which prevents certain PCs on your network from access "on-network" peripherals such as your NAS, or Media Player devices such as a Game Console (X-box, PlayStation, etc.). 2 ways to check this; one is to buy a new inexpensive router; say $60 or so that's a name brand (Cisco/Linksys or Netgear), and temporarily remove your existing Wi-Fi router and plug in the new one. Make sure to keep your Norton product disabled on the 2nd PC when you do this; and retest. If it works, your original router is causing the access problem with it's settings or it has failed. You can test this theory, by once again swapping out the new router for the original router, and performing a factory reset (FIRST WRITE DOWN ALL THE SETTINGS ON THAT ROUTER, OR USE A CAMERA-PHONE TO RECORD ALL THE OPTION SETTINGS!!! THIS CAN TAKE 1-2 HRS. TO DO; BUT IF YOU DON'T THEN ALL THOSE SETTINGS WILL BE ERASED FOREVER AFTER THE FACTORY RESET!!)
If the problem is fixed, you can now check that your 1st PC still has proper NAS access. If it does, you can begin changing the router settings, one at a time, in the original router. After some tedious testing, this make take you all day or more to do, you should have both PCs once again properly access the NAS folders correctly! :up:
6.) If everything is working after the Factory Reset on the original router, but suddenly stops working on one PC or both PCs, that setting you have just made is causing the access problem and needs to be left alone or set back to factory default and can't be used with your 2 PCs. If you wish, you can swap the routers again with the new test router, and leave everything default except that one setting, turn it back on. If it works on the test router; then that function has failed in your original router, and you should replace it with either the test router permanently or buy a newer model or different make router than your original router that has failed. This should also fix the problem. :up:
7.) Lastly, you could have failing or failed hardware in that 2nd PC; have you properly tested your hardware in that PC? And, I don't mean using built in diagnostics such as Dell, HP, Acer, etc. If that 2nd PC was upgraded to W10 from an earlier version of windows such as W7/W8x, it could be old enough to have a failing hard drive or RAM stick. This is highly likely if this PC is older than 2014 (3 yrs. old), as modern computers only have hard drives that are designed to last 3 yrs. in desktop PCs and only 2 yrs. in laptops!:eek: Test your Hardware on that PC using this excellent free TROUBLESHOOTING GUIDE I wrote available here: Windows 10 - Unclickable Task Bar

Let us know how you get on.
Best, :encouragement:
<<BIGBEARJEDI>>
 


Neemobeer

Windows Forum Team
Staff member
#4
If the NAS doesn't support a discovery protocol it won't show up and it's unlikely you have a local DNS server, so I would just connect to it by IP address. You can either give it an IP address outside of your DHCP scope or setup a reservation so the address never changes in DHCP
 


#5
If the NAS doesn't support a discovery protocol it won't show up and it's unlikely you have a local DNS server, so I would just connect to it by IP address. You can either give it an IP address outside of your DHCP scope or setup a reservation so the address never changes in DHCP
 


#6
Thanks for the interest shown in the case. It really puzzles me as some later restarts (but not all) have shown the entire set of network units, including the NAS, in the Network folders of all connected PCs. This instability of things is remarkable. To answer some of the Qs raised by you the following is a summary of the situation when the NAS is NOT present in the Networks folder

1. NAS has a fixed IP adress

2. Resources on the NAS can be accessed using the unmapped network adress of the NAS

3. Existing mappings work

4. Norton Security is not the problem which persists when Norton is inactivated (Firewall and Virus)

5. Router resetting makes no difference

So WHY is the NAS (at times) not listed in the Networks folder? How does W10 obtainn the info about network units?
 


Neemobeer

Windows Forum Team
Staff member
#7
Windows uses SSDP to discover devices.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#8
Intermittency of your resources appearing indicates either hardware failure on your 2nd PC (you haven't said you tested it yet, which indicates you probably haven't done so), or windows registry corruption.

Removing the Norton Security would also be prudent, as disabling it doesn't mean it's not the cause of the problem. You should try removing it, and using the built-in W10 Windows Defender (WD) instead, at least temporarily for Troubleshooting purposes. Several of our Admins here regularly recommend this approach.

When you reset the Router, did you perform a full factory reset? That can take from 30 seconds to 3 minutes of holding down the Reset button on the router. Hitting the Reset button for less than 30 seconds won't properly reset the router of any make/model that's out there; it simply initiates a reboot and all the settings you have in that router, whether good or bad will still be there, and you haven't completed this step until you can perform an actual factory reset. You may have to visit the router website and download the Owners Manual to get the precise factory reset instructions.

There are many reasons why the NAS comes and goes in your File Explorer listing, but they are too numerous to list here. Another possibility is that the NAS itself is faulty. Based on your description, though, the 1st PC does not have this problem, correct? That tells me that your 2nd PC is faulty rather than the NAS itself. You haven't tried everything I suggested in my rather lengthy post to test it or repair the W10 itself, up to and including W10 reinstallation on that PC. If you are not up to do this testing and won't or can't afford to pay a Tech to do the testing on your hard drive, you haven't eliminated that item as a source of your issue.:noway:

If testing your hardware intimidates you, or you simply don't want to do it or can't afford to pay to have it done professionally, you could simply purchase a new Hard Drive on ebay or amazon, such as a 500GB SATA drive, and install your W10 from factory Media (which you can make or buy directly from your PC manufacturer). Cost of such a drive should be under $65 US. Connect the 2nd PC to your network, fire up your File Explorer, and check your NAS folders. Run the 2nd PC for 24-48 hours continuously and monitor proper operation. If the 2nd PC now works properly, with the NAS resources staying put, you have narrowed down the problem to a faulty Hard Drive you had in that machine previously. :) Simply reinstall all your programs onto the new Hard Drive (or purchase another new larger capacity drive if desired), and copy back all your data and reintegrate it onto the new drive. Your problem is now solved! :up:

As far as where or how W10 gets it's information on network devices, that's impossible to answer fully on this forum, as there are hundreds, thousands of technical books and manuals dealing with this subject, and you could take several courses at private computer schools (such as New Horizons) from an authorized Microsoft Educational institution. These courses are quite expensive, and run into the hundreds to thousands of dollars. And it will take you several years to go through these courses. Many are offered online now, and of those, some are offered through University extension courses at both the graduate and undergraduate levels in different states.

In the meantime, take a look at these books if you are really interested in studying the W10 networking details:
Amazon.com: MCSA: Windows 10 Complete Study Guide: Exam 70-698 and Exam 70-697 (9781119384960): William Panek: Books
and for the Server-side of W10 networking, take a look here:
MCSA Windows Server 2016 Study Guide: Exam 70-740: William Panek: 9781119359340: Amazon.com: Books

The MCSA guides are written at a medium technical level, the MCSE guides are written at an advanced technical expert level, so most likely those would overwhelm you or put you to sleep. The short answer to your question really can't be answered as I said, but W10 gets it's network information from the cache locations in W10 registry and the contents of the networking system files within W10 located on many file locations spread throughout the hard drive in a maze that you can never hope to follow. What makes that even more difficult to understand is that those file and registry locations are spread throughout all 5 of the various Hive files that make up the database repository of W10 itself. Others may be able to explain it more simply, but you can see why that can't be answered at any kind of simple level.

Let us know how it goes.
BBJ
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.