No Wireless after installing Diablo 3 beta

#1
I downloaded the Diablo 3 beta client from the official blizzard website yesterday and ever since I started installing it I was able to connect with my wireless but not access any sites whatsoever, (for some reason aim works). I have tried connecting on the same computer with a wired connection and that works and tried using my wireless on another computer and that works.

When I try going to any sites in google chrome or try the windows troubleshooter they both give me a DNS error message.

So far I have tried:

uninstalling the game

rolling back my wireless driver

updating my driver

reinstalling "wireless console 3" (ASUS wireless program)

running ipconfig/flushdnes registerdns release and renew

scanning with malware bytes (found nothing)


Any one have any suggestions???
 


Trouble

Noob Whisperer
#2
Hello and welcome to the forum.
Yes first open a command prompt and type
ipconfig /all > desktop\ipconfig.txt
that will create a text file on your desktop called ipconfig
attach it to your next post.
In the mean time open control panel
Near the top right change the "View by:" drop down arrow to "Small icons"
Open Internet Options
Select the Connections Tab
then
The LAN settings button
uncheck every box and OK your way back out of there.
Now open IE and see if you can get to a web site.
If not in the address / URL bar at the top of your browser type
209.85.145.105
and hit enter
Does the generic Google search page open?
Regards
Randy
 


#3
Thanks for the advice and welcome Randy,

I changed the settings you mentioned and still no regular net access; however using google's IP allowed the main page to load and I could use the search engine, but just couldn't access any of the results.

Here is the attachment you requested:

View attachment ipconfig.txt
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#4
Looks like the DNS server address has got stuck at an invalid setting. Goto Control Panel, network sharing centre, change adapter settings, right click on wireless adapter, select properties, left click on tcp/ipv4 and select properties. Make sure that "obtain dns server address automatically" is ticked. This should set the dns server address to 192.168.0.1 instead of 192.168.2.1:

The entries in your ipconfig.txt which are currently:

Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 309653613
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-04-5F-06-20-CF-30-44-8C-21
DNS Servers . . . . . . . . . . . : 192.168.2.1
192.168.2.1

should show the entries of 192.168.2.1 changed to 192.168.0.1
 


Last edited:

Trouble

Noob Whisperer
#5
Looks like you have two private reserved Class C subnets involved in your IP addressing schema.
Which may be an issue if for some reason the router (192.168.2.1) is not responding to DNS queries and forwarding them or if router (192.168.0.1) is not forwarding DNS queries properly.
Without knowing exactly why you have the extra router / subnet involved in your network, I can only suggest that you configure your DNS server addresses manually at least temporarily for testing.
Click the start orb and type
ncpa.cpl into the search box and hit enter
select then right click on your Atheros AR9285 Wireless Network Adapter and choose properties
Scroll the "This connection uses the following items:" box and select / hightlight Internet Protocol Version 4 and click the properties button
Select the radio button that says "Use the following DNS server addresses:" and enter the following
Preferred DNS server: = 24.222.0.5
Alternate DNS server: = 24.222.0.33
Those are for your provider eastlink.ca OK your way back out of there and test your ability to open a web page now.
Keep us posted
Regards
Randy
 


#6
That was it patcooke!! It's working now, thank you both so very much! I have spent way too much time playing around with different solutions from following solutions for other people's similar problems on forums really wish I would have done this first lol

I thought I was going to have to reformat the computer, so glad that I didn't have to! Thank you both again!
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#7
Glad it's sorted and thanks for the feedback.
 


#8
Its the least I can do after you two put in the time to help! I find it frustrating when you see threads for help and the poster can't even be bothered at the end to give a simple thanks after people put in the time and effort to help them
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top