Old Lap top XP hard drive won't get recognized on new Windows 7 laptop

Discussion in 'Windows 7 Hardware' started by dumbfounded, Feb 5, 2010.

  1. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    Hi all,
    Old laptop had XP. Died. (no, the issue is not the hard drive).
    Got a new laptop with Windows 7. Took out hard drive from old computer (Samsung model MP0804H, IDE PATA 80 Gigs), bought a generic enclosure (that operates of two USB ports for power and data).
    Upon plugging it in I get the dialogue box which states “Installing device driver software” “USB Mass Storage Device” which eventually stops showing the pic I have attached.

    I can hear it spinning and the red and green light flashes, soon remaining almost only red.
    Disk management will not detect it nor does it appear in my computer. But it does appear in Devices and Printers as “Unspecified” (and some weird characters) (see other photo, with highlighted circle).
    Cannot for the life of me figure this out, nor can other I had asked.
    I thought perhaps I need to install the driver for the Samsung Hard drive but was assured by friend who knows more than me, that isn’t the problem as windows should install a driver automatically,
    Please help! Driving me NUTS!
     

    Attached Files:

    #1 dumbfounded, Feb 5, 2010
    Last edited: Feb 6, 2010
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Welcome to the forums, dumbfounded.


    1. Computer => Right-Click => Management => Disk Management =>

    => do you see your Hard Drive there ?

    2. When windows automatically installs new device, do you get the message that the driver has been successfully installed ?

    Did you check the option to search internet for drivers ?
     
  3. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0

    As stated above it is a generic device (no name brand) so I can't find drivers for it, & "no" to the first two questions.
     
  4. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    Just a guess, you might have a bad enclosure my first thought if it was a very inexpensive device.
    I bought one once and experienced similar issues.

    Try purchasing a name brand device.

    Newegg.com - VANTEC NexStar3 NST-260U2-BK Aluminum 2.5" USB 2.0 External Enclosure - External Enclosures

    I've bought products from this maker before and they are good quality.

    Something else, some enclosures come with a connecting cord with two connectors at one end,
    this is to ensure enough power to the device, the idea being on plug acts a data/power source and the other is power only.

    Not likely here though because if a 2.5" drive enclosure doesn't have enough power the indicator light will flash red and you will hear a clicking sound caused by the drive trying to spin up and the read\write head seeking.
    Windows won't recognize it and won't even try to install device drivers.

    I have a PATA external drive that won't work with a connector cord longer than 12" giving symptoms like the low power scenario above if I use a 1 meter cord.

    This regardless if the drive is connected to a my notebooks USB port or a Belkin Powered Hub.

    BTW, this is an excelent way to recycle an old HDD, when it works.
     
    #4 fjgold, Feb 6, 2010
    Last edited: Feb 6, 2010
  5. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    Thanks. Yes it is a very cheap enclosure ($7). So will seek a better one. Probably the issue. Will this work with windows 7 ?
    Thanks again.
     
    #5 dumbfounded, Feb 6, 2010
    Last edited: Feb 6, 2010
  6. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    No reason why it won't work with Win 7, after all it's is just another USB mass storage device.

    The Vantech device I linked to is very affordable and it has good reviews.
     
  7. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    Well I need to pay via paypal. Hopefully they have an eBay store.
    Thanks again for your help.
     
  8. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    Newegg does PayPal.
     
  9. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    Cool. I'm in Canada so hopefully that doesn't screw me over (as is often the case).
    Found two others. I may go for it as long as shipping is reasonable.
     
  10. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    Excellent! Just make sure the enclosure you pick is for IDE drives and not SATA.
    The ones you linked are IDE.
     
  11. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    Well, got a new enclosure and the same thing. Not getting recognized yet I can hear the drive revving up. The light simply flashes red and green.
    Next step?
     
  12. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    This is a longshot, but could it have anything to do with master vs slave settings? My old drive doesn't even have a jumper on it so I'm guessing the issue is moot. If the jumper setting was the issue, how would I set it to slave if there is no jumper?
     
  13. dumbfounded

    dumbfounded New Member

    Joined:
    Feb 5, 2010
    Messages:
    38
    Likes Received:
    0
    NOW, after putting the hard drive BACK in the old laptop I AM abel to power up the laptop. BUT it keeps just looping around from the windows XP opening screen to a DOS screen showing various methods of stating (ie start in SAFE mode, etc) none of which take me through. What does this suggest?
     

Share This Page

Loading...