Partition Access Denied

Discussion in 'Windows 7 Help and Support' started by jonnyollet, Jan 13, 2009.

  1. jonnyollet

    jonnyollet New Member

    Joined:
    Jan 13, 2009
    Messages:
    2
    Likes Received:
    0
    Morning All,
    I had a go at installing Windows 7 yesterday and have run into a small hiccup.
    On my XP installation, my HD was partitioned into 2 drives, C: and D: (both the C and D drives are NTFS formatted).
    C: was used for windows and program files.
    D: was used for my documents eg. videos, photos etc.

    I installed Windows 7 as a fresh install to the C: partition and the installation went smoothly.
    However, My Computer, I can see the D: drive listed, but every time I click on the icon it says "Access Denied - Drive Not Accessible"

    All my stuff is backed up on an external drive so I'm not too worried about re-formatting HD etc, but wondered why it is doing it and if anyone knew a way to get my D: drive back without formatting?

    Thanks in advance for your help,

    Jonny
     
  2. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Go into an elevated command prompt(Run as Admninstrator) and type in
    takeown /f D:\ /R /D Y

    Then try to access the drive and see. This should take ownership of the files and folders on the drive to your user.
     
  3. gcwhite1

    gcwhite1 New Member

    Joined:
    Jan 12, 2009
    Messages:
    40
    Likes Received:
    2
    Not to say what IROKEN says will not help. but ff you are dual booting, then the issue DOES lie in the permission and what he says WILL let you have access to the files that you seek, but you also MAY lose access to the other OS.

    On another note. If you are using the C: drive as the host for both OS's you could have other issues as well. When performing this type of operation you should definitely use separate partitions and if at all possible separate drives.
     
    iroken22 and (deleted member) like this.
  4. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    indeed gcwhite. I was just giving him a temporary fix and well said with the reponse. I dont think i could of said it better myself. Im uping your rep for doing such a good job.
     
  5. Kiwifrog

    Kiwifrog New Member

    Joined:
    Jan 20, 2009
    Messages:
    4
    Likes Received:
    0
    Anyone had success curing the hdd "Access is Denied" trouble? Thanks for helping if you have an answer...
     
  6. gcwhite1

    gcwhite1 New Member

    Joined:
    Jan 12, 2009
    Messages:
    40
    Likes Received:
    2
    Someone else gave me this tid-bit.

    If the issue is it not having a drive letter, follow the instructions below:

    If you go to the 'Drive Management' console. There you will see the partition containing the other OS, however you will see that it does not have a drive letter. Right click on the drive and select 'Change Drive Letter...' and once the dialog box opens, you will be able to assign the partition a letter. Just accept what it gives you unless you have a preference for a specific one. Once the part is complete you will be able to access the other partition. Not sure if you will need to reboot. I don't think so.

    If you have a drive letter, then you have an access issue that COULD be remeded by changing the permissions on the given folder. But please be ware that if you change the permissions that you may alter the access to that folder from the other OS. I really cannot speak with practice on this as I have not attempted to change permissions in such away. But changing the permissions is the only way that I am aware of that you can get access to the folders that have this issue.


    Please let me know if this worked for you. And if it does could you click my rep?

    Thanks and good luck.
     
  7. Kiwifrog

    Kiwifrog New Member

    Joined:
    Jan 20, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks for the info. Discovered that sometimes you have to manualy mount drives with W7. After a bit a mucking around I decided to reformat and reload my archives on the HDD :(. The 32b version was blocking access on a drive that was perfectly accessible to the 64b version, Vista and XP.

    Cheers.

    Windows 7 is close to what we expected from Vista, it should be released as Vista SP2! ;)
     
  8. JohnnyL

    JohnnyL New Member

    Joined:
    Feb 6, 2009
    Messages:
    10
    Likes Received:
    2
    I had a second hard drive that was giving me a "not accessible" message. On installation W7 had assigned it a drive letter so it showed in Disk Managment but I couldn't access anything on it. Turns out the only group that had any kind of permissions for this drive was the System. All my other partitions on the other drive and even the USB drive had at least 4 entries in permissions...things like System, Administrators, and Users with various boxes checked off. The Hard drive I couldn't access, only had system listed as having any kind of access permission. I had to add everything else, take ownership, etc to gain access. When I booted back to XP I still had access to that drive.
     
    gcwhite1 and (deleted member) like this.
  9. gcwhite1

    gcwhite1 New Member

    Joined:
    Jan 12, 2009
    Messages:
    40
    Likes Received:
    2
    Thanks for the post. I was wondering about that very thing!
     
  10. Bestvue

    Bestvue New Member

    Joined:
    Feb 4, 2010
    Messages:
    2
    Likes Received:
    0
    Partition Access

    Have recently installed W7 to find my hard disk ( it has 4 partitions C,D,E,F) No problem on CDE but "F" although was there could not get access.
    It surly is a "permissions" problem;

    I correct the permissions and succeeded in accessing the drive. :p
    Now I can see all the folders and files in explorer but can only open them when I apply the permissions to each individual file and folder.
    After getting bored with this after the first 50 or so files I visited this forum and
    --------------------------------------------------------------------------------------------------------------------------------------
    Go into an elevated command prompt(Run as Admninstrator) and type in
    takeown /f D:\ /R /D Y
    Then try to access the drive and see. This should take ownership of the files and folders on the drive to your user.
    ---------------------------------------------------------------------------------------------------------------------------------------
    It didn't do any harm but it didn't do any good either.:(

    Does any body have any idea as its a 70GB partition and FULL
    any quick way ??
    Help please
     
  11. kvenkatesan

    kvenkatesan New Member

    Joined:
    Sep 23, 2011
    Messages:
    2
    Likes Received:
    0
    hai jonnyollet
    [​IMG]


    i think this post may solve your problem because i am also getting the same problem.that means
    i had already installed windows 7 pro.and i am facing so many problems so i planed to reinstall the os with windows xp pro.i had 2 hdd and 8 partitions.but two partitions are when i open the drive after reinstalling the windows xp pro the two drives are getting "ACCESS DENNIED" error.

    so, i tried to solve with some way and solved the problems for me.so i want to share that

    1. download and write Hrens boot cd 13.2 or any latest version

    2. boot with hiren cd

    3. find your "acces denied" partition

    4. click right click and open properties in mentioned partition

    5. now you will see the security option.

    OR

    remove the hdd and connect to the any other cpu with windows 7 os machine

    then follow the below step


    Windows 7 Access Denied: Permission & Ownership
     
    #11 kvenkatesan, Sep 23, 2011
    Last edited by a moderator: Sep 23, 2011

Share This Page

Loading...