Permissions problems (Program Files folder?)

Discussion in 'Windows 7 Help and Support' started by DStruck, Aug 6, 2010.

  1. DStruck

    DStruck New Member

    Joined:
    Aug 6, 2010
    Messages:
    4
    Likes Received:
    0
    Hi all, I'm running into three issues which I'm guessing are related --

    1) Windows 7 seems to protect certain folder trees differently than others. In particular, the Program Files tree. If I try to copy a file to a folder in that tree or rename a file in one of the folders, I get a dialog that says "Destination Folder Access Denied: You'll need to provide administrator permission to copy to this folder." I then hit the Continue button and it copies. This is just an annoyance but happens all the time since there are plenty of instances where I need to make copies to this folder tree (e.g. copying a distribution file to Tomcat).

    2) If I want to create a new file in one of these "protected" folders, I right-click to get a context menu -- the "New" menu only has one option, which is Folder. If I were to right-click the desktop, I would have options for Text Document, Excel Spreadsheet, etc. Those are missing.

    3) If I open a text file in an editor (e.g. NoteTab) and make edits, I can save without error. But if I then reopen the file, the edits have not taken. I can save, but not really. And Windows 7 doesn't warn me about this.

    I understand that I might be able to somewhat solve #1 by adjusting the User Account Control settings, but I don't want to lose the dialog that pops up to ask me if I want to allow a program to change the computer -- I just want to lose the dialog that prevents me from doing any simple tasks within the Program Files folder tree.

    Any thoughts?

    Thanks,

    David
     
  2. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    You can configure the UAC to "Notify me only when programs try to make changes to my computer".
     
  3. DStruck

    DStruck New Member

    Joined:
    Aug 6, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks, zvit, I tried playing around with the UAC settings, but to no avail. In the meantime, my workaround is to take ownership of the folder I'm working in. I installed Ultimate Windows Tweaker to add a "take ownership" menu item to the Windows Explorer context menu. When I take ownership of a folder, it allows me to copy to it without warning. I also get all the menu items I was looking for under the New menu in the context menu, and I can edit files in the folder without trouble.

    David
     
  4. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    I cannot duplicate this problem, I just changed the CPUZ read me file in CPUZ under program files/CPUZ saved it to desktop then moved it to Program files/CPUZ, I repeated the process and then save it to Program Files CPUZ with no problems

    You may want to under security tab for program files add everyone and then set the permissions to what you want, this may help you
     
    #4 Super Sarge, Aug 9, 2010
    Last edited: Aug 9, 2010
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Any chance you could alter your procedures and try using a folder that is not considered critical by Windows?
     

Share This Page

Loading...