Print window triggered by e-mail link

prosperus

Well-Known Member
#1
After getting used to working with Windows Live Mail, a problem started as I would click on a link inside the e-mail, that normally would automatically open a browser window leading to more info on the e-mail topic.

2 weeks ago, when I'd click on a link in the e-mail, a Word document would open instead of a browser window.

So I uninstalled Microsoft Office 2010 version and thought that would solve the problem.

Then a few days later, when I'd click a link again in an e-mail, the window opened to print, on all links of every e-mail that should have opened browsers.

I noticed that I still had Windows Office 2007, so I uninstalled it also, but am left with the print window opening whenever I click a link in an e=mail.

Any suggestions? Thank you
 


Trouble

Noob Whisperer
#2
Hello and welcome to the forum.
Open control panel and change the view by: drop down from category to small icons (top right corner)
Select the link that says Default Programs
and then the link that says Associate a file type or protocol with a program
There are in effect two lists so scroll down very near the bottom to where the "Protocols" list begins
Select HTTP and click change program or just double click it and select the browser of your choice
Same with HTTPS
See if that helps at all with your problem. If not post back and we'll examine other options as you may have to scroll up into the first list and do the same with .htm and .html
Keep us posted
Regards
Randy
 


prosperus

Well-Known Member
#3
Hello and welcome to the forum.
Open control panel and change the view by: drop down from category to small icons (top right corner)
Select the link that says Default Programs
and then the link that says Associate a file type or protocol with a program
There are in effect two lists so scroll down very near the bottom to where the "Protocols" list begins
Select HTTP and click change program or just double click it and select the browser of your choice
Same with HTTPS
See if that helps at all with your problem. If not post back and we'll examine other options as you may have to scroll up into the first list and do the same with .htm and .html
Keep us posted
Regards
Randy
Thanks for the suggestion Randy...

I got as far as seeing the "Protocols" section near bottom of list, but didn't see "http or https" on the list.

There was only a choice of 4 Protocols :

LDAP

MAILTO (Windows Live Mail) which is my current default and has worked fine until a couple fo weeks ago when this started

MMS

SEARCH
 


Trouble

Noob Whisperer
#4
Interesting.
What Browser are you using as your default?
Check the top file association list for
.htm
.html
.shtml
.xht
.xml
and see if they are currently associated with your default browser
and also check
.url
mine is currently showing "Internet Browser"
With no HTTP, HTTPS or FTP it sounds like perhaps like something (browser) didn't register properly when installed.
Try launching and elevated (run as administrator) command prompt and type
sfc /scannow
and hit enter
See if the native System File Checker finds any problems.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Could the fact Windows Live Mail is being used be relevant?

I don't use it, but are there any settings on the online version that could effect how things are handled? I don't think Live Mail is related to Office, but I certainly could be wrong.

If you copy the link and put in a browser, does it work? Does anything show on the bottom of the window when you hover on the link regarding the URL address or something else?
 


Trouble

Noob Whisperer
#6
Hey Saltgrass;
Thanks for the input. I suppose anything is possible, not being a Live Mail users either, I couldn't really say.
But according to what the OP has stated thus far, it would seem that some critical Protocols missing from the list that would normally allow association with a particular application.
The OP may need to start with the "Set program access and computer defaults" link in the "Default Programs" console and begin with what is reflected there regarding default email program. Or possibly the "Set your default programs" link and select the program there and choose the "Set this program as default" link.
With two previous installations of Microsoft Office Suite and subsequent removal of both may have left the file extension association without the proper settings.
Thank Again
Randy
 


prosperus

Well-Known Member
#7
Interesting.
What Browser are you using as your default?
Check the top file association list for
.htm
.html
.shtml
.xht
.xml
and see if they are currently associated with your default browser
and also check
.url
mine is currently showing "Internet Browser"
With no HTTP, HTTPS or FTP it sounds like perhaps like something (browser) didn't register properly when installed.
Try launching and elevated (run as administrator) command prompt and type
sfc /scannow
and hit enter
See if the native System File Checker finds any problems.
I have IE as my default

For htm and html, the defaults are Microsoft viewers

For shtml and xhtis also Microsoft viewers

For xml the default is notepad

cmd promt didn't find any violations

Also, under .url it too says internet browser

Hmm...
 


Trouble

Noob Whisperer
#8
I have IE as my default

For htm and html, the defaults are Microsoft viewers

For shtml and xhtis also Microsoft viewers

For xml the default is notepad

cmd promt didn't find any violations

Also, under .url it too says internet browser

Hmm...
Reopen the default programs console from within the Control Panel Applet
Click the
"Set your default programs" link
In the left column select "Internet Explorer"
At the bottom select
"Set this program as default"
See if that has any impact on the problem
 


prosperus

Well-Known Member
#9
YeSSSS.....that did the trick. Glad we tracked down the missing piece...

Thanks all the help....have a GREAT rest of your day :p
 


Trouble

Noob Whisperer
#10
Excellent. Thanks for posting back and letting us know that you managed to resolve your problem.
Thought for a minute that Clark was going to have to work some of his magic with "assoc" from a command prompt.
Was wondering, after you got it working properly did you happen to recheck the default programs "Associate a file type or protocol with a program" just to see if the missing protocols (HTTP, HTTPS and FTP) were back and associated properly.
Just something that may help me in the future and prevent any wild goose tangents.
Thanks
Randy
 


prosperus

Well-Known Member
#11
Yes, the http and https are NOW showing Internet Explorer...thanks again
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.