RAID Driver Messed Up and I'm Confused

Discussion in 'Windows 7 Help and Support' started by supermarioworld, Dec 9, 2013.

  1. supermarioworld

    Joined:
    Dec 9, 2013
    Messages:
    1
    Likes Received:
    0
    Hi,

    I believe one night my RAID driver crashed and now Windows doesn't see my array.

    Some History:

    One night I was trying to use Glassfish outside of Netbeans, but my website wouldn't work. So, I try to close Glassfish and went back to Netbeans because I know my site worked fine through there. Anyway, the icon didn't seem to respond, so I clicked like 3 times - in task manager I could see Netbeans running 3 instances, so I forced those to close. Well, somewhere in this mess of events popped up a critical message about my array. The computer became generally unresponsive, so I restarted out of frustration. Windows wouldn't startup anymore, so I started investigating. I tried to boot in safemode, and it wouldn't boot, but what I noticed was that the file ahcix64s.sys was where the computer would hang. Fine, so I used a Ubuntu live cd went and moved the file outside of c:\win\system32\drivers just to preven the hang. The system now starts, but without my array.


    My setup:

    I have Win 7 Ultimate x64 installed on a small drive via IDE, then I have a RAID 1 mirror composed of 1TB's drives via SATA. The BIOS is currently set to RAID mode. There's also an optical drive that uses the SATA controller.

    Mobo is BIOSTAR (780G M2+ SE), and I use an added graphics card. CPU is AMD based.

    (Likely unrelated info, but I had a casualty: I have on another drive a beta version of Win8, but I may have broken that in an attempt to repair the Win7 problem. It wont boot normally or safemode.)

    What I've done so far:

    I uninstalled the RAID from the controllers and reinstalled in the management console. The current driver has been updated to a 2012 version of AHCIX64S.SYS, but I believe the previous one used said something like amdBLAH.sys.

    I don't know which is the correct driver to use now. The computer sees my drives from the array, but doesn't show the array in explorer nor individual drives in explorer. Only disk management shows 2 independent drives with online status. In essence the array doesn't seem to be recognized or the drive letter is missing. I think if I used a different driver that my problem would be solved, but on the other hand, I feel tempted to assign a new drive letter.

    Can anyone help me out?

    Thanks.
     

Share This Page

Loading...