READ ONLY problems

Discussion in 'Windows 7 Help and Support' started by bluebrutal, May 9, 2009.

  1. bluebrutal

    bluebrutal New Member

    Joined:
    May 9, 2009
    Messages:
    4
    Likes Received:
    0
    I find it ironic that I've encountered a problem that I've never seen before in any WIndows OS, but have encountered in almost every single Unix-based operating system I've ever used. It's a phenominally stupid problem, too.

    I can't change the status of some files/folders away from Read Only.

    I transfered my music files from my backup drive to my Wondows 7 music folder. Some of the files - not all, mind you, just some of them - were magically converted to being read-only. I don't want them to be read only, but more importantly I want to be able to select a folder and recusively change the read-only status of all files within that folder.

    I tried the right-click and Properties, but the flag just keeps going back to Read Only. I tried the attrib command from cmd.exe, but it has no effect whatsoever. When attrib didn't work, I came here.

    <edit>
    As a fun side note, after individually checking each and every file in the folder, none of them actually have the Read-Only status, but the properties of the folder keep insisting that they do. Can someone explain to my how this makes sense? Like, and sense at all?
     
    #1 bluebrutal, May 9, 2009
    Last edited: May 9, 2009
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Are you able to run these files and move or copy them between directories?

    If it doesn't cause any problems, I wouldn't worry about.
     
  3. Kevj

    Kevj New Member

    Joined:
    May 9, 2009
    Messages:
    80
    Likes Received:
    2
    MS has issued a 'fix' yesterday for the problem with Security/folder permissions; if you don't have Windows Update set to automatically download, then do a 'check updates' - you'll probably find an update waiting there. This will 'fix' the problem. :)
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I don't think that's a permission problem though.

    You usually get an access denied message for permission problems.

    But feel free to give it a try.
     
  5. Kevj

    Kevj New Member

    Joined:
    May 9, 2009
    Messages:
    80
    Likes Received:
    2
    Found the MS article :

    (...In the English version of Windows 7 Release Candidate (build 7100) 32-bit Ultimate, the folder that is created as the root folder of the system drive (%SystemDrive%) is missing entries in its [COLOR=#c80000 !important][COLOR=#c80000 !important]security[/COLOR][/COLOR] descriptor. One effect of this problem is that standard users such as non-administrators cannot perform all operations to subfolders that are created directly under the root. Therefore, [COLOR=#c80000 !important][COLOR=#c80000 !important]applications[/COLOR][/COLOR] that reference folders under the root may not install successfully or may not uninstall successfully. Additionally, operations or applications that reference these folders may fail.

    For example, if a folder is created under the root of the system drive from an elevated command prompt, this folder will not correctly inherit permissions from the root of the drive. Therefore, some specific operations, such as deleting the folder, will fail when they are performed from a non-elevated command prompt. Additionally, the following error message appears when the operation fails:

    Access is denied.

    Furthermore, the missing security descriptor entries protect non-admin file operations directly under the root.

    A hotfix is available as an important update that should be delivered and installed automatically by Windows Update, assuming you have set up automatic updates. On one test system that I checked just now, the update had already been installed overnight. On two other systems, the update had been downloaded but was awaiting installation.

    The hotfix package fixes the security descriptor of the root of the system drive, but it does not repair applications that are already installed, nor does it affect the permissions of folders that were created after the installation.

    If you installed the x64 version of Windows 7, you are apparently unaffected by this issue.

    If you haven’t yet installed the Windows 7 RC, it’s important to install this hotfix after you set up Windows and before you install any programs or restore any backed-up data....)
    End Quote.

    Best check updates to see if it's waiting there. Should solve the issues. :)
     
    1 person likes this.
  6. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    OK kevj,

    I'm on Vista right now, put I'll give it a try on 7.

    Thanks
     
  7. bluebrutal

    bluebrutal New Member

    Joined:
    May 9, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks

    I was trying to use the files in the folder with another program, and was getting access denied errors... but the patch seems to be working.

    Thanks, Kevj - your response described my problem to a T, and when I got up this morning, lo and behold, it was fixed. Weird. I've never had such an "ask and ye shall recieve" response from any OS...

    reghakr - I only discovered the problem because it was causing me a... er... problem. Not worrying about it wasn't really an option...:frown:

    But everything's cool now. Thank you Microsoft, and thank you Kevj for your help, too.
     
  8. Kevj

    Kevj New Member

    Joined:
    May 9, 2009
    Messages:
    80
    Likes Received:
    2
    You're very welcome, glad to have helped :)
     

Share This Page

Loading...