Windows 8 Realtek HD Audio and 5.1 sound problem with Windows 8

#1
Hi,

I have already done a search on this forum to see if anyone has been having a similar problem and many do, but so far no suggestions have helped me......

My problem is I have an Acer 6920G laptop running Windows 8 (and 7 on another drive) and no matter which Realtek audio drivers I use, I cannot get 5.1 digital output sound to my Creative Inspire 5.1 system. I have the correct optical cable (which worked fine on Windows 7) and I am currently using Realtek v2.70 HD Audio drivers. When I select the digital output, I can only select properties and not configuration (which is greyed out) and therefore this is no option to setup a 5.1 speaker configuration.

If I use the internal speakers built-in to the laptop (for 5.1 sound) I have no problems, but not with the external speakers.

Any suggestions or help would be much appreciated.

Thanks,
Jez
 


davehc

Essential Member
Premium Supporter
#2
Way back I started having problems, on new installations, with Realtek. Now I stick to the robust Vista R263 drivers, and install it in compatibility mode. - Works every time.
 


#3
Way back I started having problems, on new installations, with Realtek. Now I stick to the robust Vista R263 drivers, and install it in compatibility mode. - Works every time.
Thanks for the reply. I have tried the drivers you suggested and although they install fine, I still do not have any options for configuring a 5.1 speaker setup as configure is still greyed out. I have taken a few screen captures from my laptop.

18_09_2012_08_54_38.jpg

18_09_2012_08_49_38.jpg

18_09_2012_08_50_02.jpg

18_09_2012_08_50_45.jpg

18_09_2012_08_46_47.png

Not sure what else I can do?????

Regards,
Jez
 


#4
Just downloaded a 5.1 WMA sound test and that worked fine through all speakers even though they are not configured for 5.1 which is strange buy hey it works :)

I`m now going to try a blu-ray film with 5.1 Dolby Sound and will see if that works as well. I will probably use VLC player to play that on my laptop. I`ll update later on this morning.

Regards,
Jez
 


#5
Played the blu-ray and 5.1 sound is now working :) Not sure how it suddenly works, but I'll leave things as they are for now.
 


davehc

Essential Member
Premium Supporter
#6
Good policy! If it works , leave it alone.
 


kos

New Member
#7
i installed latest driver for my new logitech z506 and when i do the test to the speakers its fine BUT when i listen to anything else,only my front right and left speakers work!can anyone please help me?
 


davehc

Essential Member
Premium Supporter
#8
You might get more help if you start a new thread with your problem. This one is very old.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.