Remove duplicate default program entry

Jimmy59601

Senior Member
After a bout with some malware, I found that I have two entries for Firefox in my list of default programs in Win 10 settings. One won't let me pick Firefox as the default browser when I choose that one. I want to remove it from the list. Is there a way? See the screenshot. Thanks!
37137
 


davehc

Essential Member
Premium Supporter
perhaps it might help if you look in the Programs and features (Setting - Apps, and, on the right) and see if you possibly have two entries of different versions there
 


Jimmy59601

Senior Member
perhaps it might help if you look in the Programs and features (Setting - Apps, and, on the right) and see if you possibly have two entries of different versions there
Did that. Only one. My guess it the legit FF. I probably do some research on the registry, as I'd bet it's there somewhere.
 


davehc

Essential Member
Premium Supporter
Maybe if you unistll FF , you can then find the other and delete it manually. Easier enough to reinstall.
 


Jimmy59601

Senior Member
True, but there is only one FF on my system, in any of the customary folders, and I don't think the remaining one will show up after reomving the real FF. My guess is that it's a, phantom entry with no artifacts in my folder structure. I'll run a search of the registry first
 


Neemobeer

Windows Forum Team
Staff member
I was able to replicate your issue by installing two versions of Firefox, so for starters open "Add/Remove Programs" and verify you don't have two versions installed. If you don't then it's most likely a registry key left over for the old version.
 


Neemobeer

Windows Forum Team
Staff member
To locate the keys
  • Click on Start
  • Type regedit
  • Expand the HKCR hive
  • Scroll down to FireFoxHTML-
Each version of FireFox will produce a FireFoxHTML-####### and FireFoxURL-#####. If you're on the current version of FireFox (63.0.3) then the correct two keys will be HKEY_CLASSES_ROOT\FirefoxHTML-308046B0AF4A39CB and HKEY_CLASSES_ROOT\FirefoxURL-308046B0AF4A39CB you should be able to delete the other HTML/URL pairs.

Once removed you will need to close and re-launch System Settings
 


Jimmy59601

Senior Member
Yes!! That did the trick. Thanks very much for sharing your expertise.
 


Jimmy59601

Senior Member
I solved the problem. It was with a Firefox shortcut that I placed on the Taskbar. The shortcut opened FF to my home page, my.yahoo.com. I found that. if I opened FF from a Taskbar shortcut that opened Google.com, the issue did not occur. I deleted the problem shortcut and created a new one that also opened FF to my.yahoo.com and the problem did not present or recur. Regardless, thanks very much for your help!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top