removing virtual disks

zabberwan

Honorable Member
#1
All of a sudden I have 4 Removable Drives on my windows 8 machine. I've tried removing these, but they return as soon as I restart.
I went into computer/disk management, right clicked each and uninstalled the driver, but no way. So I went to Device Manager and first disabled and then uninstalled each one of them, but still they exist immediately on restarting the system. They react to "eject" on right-click by stating
The disk drives as seen in Device Manager are:
  1. Generic - Compact Flash USB Device
  2. Generic - MS/MS-Pro USB Device
  3. Generic - SD/MMC USB Device
  4. Generic - SM/xD-Picture USB Device
Any ideas how to fix this problem?

Regards to all :)
 


#2
What you're seeing are placeholders for the various flash memory card readers in a bank of sockets on your computer. They normally have drive letters assigned. It isn't an "error". Thumb drives or external hard disks that you plug directly into a USB port get a drive letter assigned when they are plugged in. The card reader sockets are already plugged in (the card reader is what gets the drive letter, not the media card you insert in it).
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
I suppose it could also be such devices on something like a printer. Have you tried setting the Folder View Properties to Hide Empty Drives.
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#4
What you're seeing are placeholders for the various flash memory card readers in a bank of sockets on your computer. They normally have drive letters assigned. It isn't an "error". Thumb drives or external hard disks that you plug directly into a USB port get a drive letter assigned when they are plugged in. The card reader sockets are already plugged in (the card reader is what gets the drive letter, not the media card you insert in it).
Well put… they could also be drives that have been stored in your bios as possible boot devices if you have been playing around with the boot settings? You can log into the bios and see the listed boot options… any old usb settings can be safely deleted as long as you keep the “windows manager” all the others will just be added back in if required at some later date.
 


zabberwan

Honorable Member
#5
Thanks for the input folks.
Yesterday, I disabled these in the Device Manager and they stopped showing up under Computer and that is okay to go on for the moment. But, it's still a mystery why they just started showing up without me doing anything to trigger it off! I'll definitely look it up in the BIOS one of these days. The weather is so nice..(touch wood and all that!)
 


#6
Glad you solved your problem. The real question, though, is why they didn't show up all along (unless, as Saltgrass suggested, they are on your printer and you only recently connected it).
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#7
That sounds like what I see for my card reader when I don't hide it.
When I apply "Hide Empty Drives in Computer Window", in View Options they don't show, unless I plug something into them.
 


zabberwan

Honorable Member
#8
I suppose it could also be such devices on something like a printer. Have you tried setting the Folder View Properties to Hide Empty Drives.
Yes, it was in Printers and Devices. Under File Options it was set to "Hide empty drives".
The Culprit.jpg


Something was wrong with it.
So I let the system check and fix it. It couldn't because the devices were disabled in Device Manager. So enabled them first and let the system "Troubleshoot". It said that it fixed.
Voila! No more "Removable Drives"!
Here's drinking to ya all!
Cheers
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.