RSA SecureID Application Issue (App-V)

Discussion in 'Windows 7 Help and Support' started by WackWack, Dec 14, 2013.

  1. WackWack

    WackWack New Member

    Dec 14, 2013
    Likes Received:
    Hoping to get some help on an issue that I have been hard pressed to find a solution for. I have an end user that currently works in a department that utilizes an application called RSA SecureID that runs in App-V. This application allows for remote VPN access to the internal corporate network.
    Over the past few days we have been rolling out Microsoft Security updates to the environment and upon doing so, has caused this application to stop working. The error is as follows:
    RSA SecurID Software Token
    Failed to open token service.:Error in TKN library:password validation failed

    I have tried clearing the App-V cache, uninstalling the application & performing a re-install. The same error appeared after these steps were completed. I ran this application as Admin while logged into the user's profile & it started working just fine. This confirms that there is some sort of .db file within the users profile that is causing this error to occur. I am certain that performing a Windows profile rebuild on this user's account would correct the error but I am doing whatever I can to avoid this. I also made sure that one of her co-workers was able to logon to the computer and successfully run the application.
    This application uses a imported password to verify the logged in user's credentials. From what I've found, it stores the .db file in C:\Program Files (86)\RSA SecureID but after install I do not see this file path. I believe this is due to the fact that it is virtualized.
    My question for you folks is where exactly are the data files stored for App-V. I have searched high and low and even dug into the registry to find these data files.

    Any help would be greatly appreciated & if you have any ideas on how to solve this issue I would be more than grateful.

    Good Day!

Share This Page