Security issue since upgrade to 8 from 7

Discussion in 'Windows 8 Help and Support' started by Andrew G, Sep 12, 2014.

  1. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    Sorry for the long post, I've tried everything for this issue. I tried asking on other forums and nobody could really help me cause it's an 8.1 thing. It's taken me a long time to figure all this out so I'm slightly discouraged....

    Ever since I upgraded from Windows 7 to 8.1, I've had a problem with this game I play. Whenever the game itself starts or I try to save/load from within the game, I get a message saying "Failed to Open File. It may have read-only settings, lack permission support, or not enough space on the hard drive." The game actually runs fine, but this message constantly pops up.

    The game is on drive D and the save files by default are saved to drive C. I found if I delete the C folder, I can start the game normally, and it just creates a new, blank C folder without my saves. But when I move my saves back over, it happens again. So it has to be a security issue that 8.1 isn't getting along with the 7 files specifically.

    I have plenty of space on the HDD so I KNOW it's a security issue. And I've tried just about everything. Including everything from

    http://www.eightforums.com/tutorials/2815-permissions-allow-deny-access-users-groups-windows-8-a.html

    and

    http://www.sevenforums.com/tutorials/63741-read-only-file-folder-attribute.html -Several but not all of these


    If I try to deselect the Read Only option in Properties, it reverts back as soon as I close the window. I've done everything I can in the Properties/Security settings, changing both access and permissions to several accounts.

    So that about sums up where I am. ANY help is appreciated! Save me Windows forums, you're my only hope...
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Right click the problem Game Files Folder on C and choose properties.
    Select the Security Tab
    Click the Edit Button
    Click the Add Button
    Type the word
    Everyone
    Into the box that is labeled "Enter the object names to select
    Click the Check Names Button
    Click OK
    Now select the Everyone group and check the Full Control check box and click OK
    Now select the Every group and click the Advanced Button
    Click the Disable inheritance button
    Click Convert inherited permissions into explicit permission on this object
    Check the box that says Replace all child object permissions entries with inheritable permissions entries from this object.
    Click apply
    Click yes when prompted if you want to continue
    Click OK
    Click OK again
    You may have to reboot or at least log off and log back on for your account to receive a new access token with the new permissions.
     
  3. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    Ugh it didn't work. I can't believe it didn't work either.

    That seemed so perfect too, everything was just as you said except for one thing. Once I got to the "Click the Disable Inheritance button," it already said Enable Inheritance. So I clicked it, then it said Disable, so I clicked it again, and everything after that went as planned.

    I also discovered that I have control of the actual files. I went all the way back to the "Users" folder on the C drive and found that even that folder would reset Read Only every time. However if I go to ANY file in there, I can enable/disable Read Only without any issue.

    ...How does this make sense!! How can I change files but not folders? I don't get how everything I've done so far hasn't given me full, absolute control over this thing!

    I really like Windows 8, but this is driving me crazy!
     
  4. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    So maybe it did work. Kinda. I think...

    I found that at this point I actually can copy the individual files over to the new folder and....it works!! I tried this before and it didn't work, but after this method I tried again, and sure enough...However even in the new folder, if I try to change the actual folder's Read Only setting, it still reverts when I hit Ok. But not the files inside the folder. Weird.

    The C folder is in Users/MyUser/My Documents, don't know if that means anything. Only other option in Users is the Public file.

    But anyways, I'll take this as a solution as I can at least get the game and my main save to start without that annoying message. Thank you so much Trouble!!
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to have helped and thanks for posting back and updating your thread with that information.
    And don't worry about the read only attribute on the folder(s) it shouldn't interfere with anything you're trying to do and it really doesn't mean what you think it means anyway.
    Source: http://support.microsoft.com/kb/326549
     
  6. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    Thanks, that linked actually did explain a lot.

    If I can ask one more question, I did make a bunch of security changes. Did I open any back doors for viruses or hackers or anything? I use AVG free, and to my knowledge it should be ok, but figured I'd confirm...
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I have no way of knowing what you actually did, but....
    If the target was only that single folder then I wouldn't suspect any problems.
     
  8. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    Well pretty much everything in those links is what I did (except maybe the last 2 or 3 things in the second one), along with what you said.

    But yeah, I don't think so. I'm not TOTALLY computer illiterate and nothing stands out that would be a major security risk...
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    NTFS permissions (what you are adjusting under the security tab) only impact users who are logged on locally.
    It's when you start sharing and use the sharing tab to grant permissions to shared resource that it could possibly be accessed across a network. That is when share permissions and ntfs permission are meshed and the most restrictive applies.
    http://www.techexams.net/technotes/70290/permissions.shtml
    That is an old article and the interfaces look a bit different now but the rules and underlying principles are still pretty much exactly the same.
     
    Andrew G likes this.
  10. Andrew G

    Andrew G New Member

    Joined:
    Sep 5, 2014
    Messages:
    19
    Likes Received:
    1
    So just an update to clear up confusion, the issue ended up being game specific but was caused by the OS upgrade. I guess the saves folder has this one file that sort of links the program to being installed to "that user" or something along those lines. I'd never noticed it before but it was in the saves folder and I didn't have a save game matching that file name. So when I went from 7 to 8, I guess that file was still searching for the Win7 user.

    So I just deleted that file, the game automatically regenerates one when you start it, and haven't had the problem since! Again random side effect from updating your OS, but I guess anything's possible!

    PS and for future Google search reasons, I'll include the name of the game: Roller Coaster Tycoon 3
     

Share This Page

Loading...