Windows 10 Set Associations File in Windows 10 64bit

Discussion in 'Windows 10 Help and Support' started by EdAWood, Dec 18, 2015.

  1. EdAWood

    EdAWood Senior Member

    Joined:
    Mar 30, 2011
    Messages:
    17
    Likes Received:
    0
    I am running Windows 10 Pro on an i7 Dual Core 3.5mb with 16gb memory on an Aesus Box.

    I have Adobe Acrobat 10 installed on my system. Adobe Reader XI is also installed (by some program) on my system, and is the default programs for .pdf files.

    I have accessed the Set Associations File through the Control Panel and tried to change the default program for .pdf files from Adobe Reader to Adobe Acrobat. However, when I click ok to make changes, it automatically defaults back to Adobe Reader. I can change from Adobe Reader to Adobe Acrobat on all other file extensions that are read by Adobe but not the .pdf.

    Does anyone have any suggestions? I would really appreciate the help. The only solution that I am aware of is to delete the Adobe Reader XI program which I can do if necessary.

    Regards,
    Ed Wood
     
  2. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,397
    Likes Received:
    360
    Some products fight over association. I don't recall Adobe doing this though. You can also try right clicking a PDF and select "Open With". Select Choose another program, check the box to always open and select Acrobat. You could also try the 3rd party utility FileTypesMan - Alternative to 'File Types' manager of Windows
     
  3. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    Sorry, I see that Neemobeer has suggested the same thing, I should have read the message through to the end.

    But since I typed it anyway...

    Click on a .Pdf file in Windows File Explorer, select Properties and change the Open With setting to Acrobat.

    Mike
     
    #3 MikeHawthorne, Dec 18, 2015
    Last edited: Dec 19, 2015
  4. EdAWood

    EdAWood Senior Member

    Joined:
    Mar 30, 2011
    Messages:
    17
    Likes Received:
    0
    To Neemobeer and Mike.

    Thanks for the tip. I have already done as you suggested on right clicking on the file and choosing "open with" and making that the default program. However, I have to do that EACH TIME I reopen the file(s). That is why I was trying to make the change in the "Set Associations" file.

    I will d/l the little utility program that Neemobeer suggested and see if I can accomplish my task using it. If that doesn't work, I will delete Adobe Reader IX. I don't really need it because I can accomplish the same purpose in Adobe Acrobat and more!

    Thanks for the suggestions, and Merry Christmas!

    Ed Wood
     
  5. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    I've changed my previous post as, upon reflection, I think you may have a registry or Adobe problem. Whether the GUI or assoc/ftype commands are used, the result is the same - an updated registry.

    Have a look at the registry. Run regedit and navigate to HKEY_CURRENT_USER\Software\Classes. Scroll down in the left pane for .pdf which has the ftype default in the right pane. Now scroll further down in the left pane for the ftype then in shell\open\command.

    If the keys are not present, look in HKEY_LOCAL_MACHINE\Software\Classes.


    Here is a little more information that's worth digesting regarding locations and precedence:

    1. Display all extensions and their associated file types by firstly copying the following 4 lines:
    assoc >"%userprofile%\desktop\assoc.txt
    start notepad "%userprofile%\desktop\assoc.txt
    exit
    cls

    Using Command Prompt (Admin) right-click and paste the above 4 copied lines. A .txt file is created on the Desktop and Notepad will open and display the list. The list represents the registry keys located in the merged HKEY_CLASSES_ROOT.

    2. Now display all file types and their associated programs by substituting the above 4 lines with these:
    ftype >"%userprofile%\desktop\ftype.txt
    start notepad "%userprofile%\desktop\ftype.txt
    exit
    cls

    Another .txt file is created on the Desktop and Notepad will open and display it. This list represents the registry keys in HKEY_CLASSES_ROOT further down beyond the extensions.

    3. NOTE. In operation, any keys in HKEY_CURRENT_USER\Software\Classes (current user) take precedence over those in HKEY_LOCAL_MACHINE\Software\Classes (all users) and both keys appear as the merged HKEY_CLASSES_ROOT. Any changes should be made to HKCU and HKLM. The HKEY_CLASSES_ROOT keys are intended to be read from, not written to.
     
    #5 BurrWalnut, Dec 19, 2015
    Last edited: Dec 20, 2015
  6. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    You might also just try uninstalling and reinstalling Adobe Acrobat.

    If you do don't install it to the same directory that it was before, you want Windows to see it as a new program and not use old settings.

    After you uninstall it I'd run CCleaner's registry checker to get rid of leftovers.

    Mike
     
  7. EdAWood

    EdAWood Senior Member

    Joined:
    Mar 30, 2011
    Messages:
    17
    Likes Received:
    0
    Thanks, guys, for all of your help. I think that my wife is installing Adobe Reader when she goes to a webpage that has a .pdf file she wants to read and the page tells her she has to have Adobe Reader installed to read it. She clicks on the button to install the program and overrides Adobe Acrobat as the default reader.

    I have cautioned her not to install Adobe Reader. I stressed to her that I have Adobe Acrobat installed and Adobe is not needed.

    Have a great week!

    Happy New Year.
     

Share This Page

Loading...