SOLVED: Cant open store

qavorq

Honorable Member
#1
Can anyone tell me a simple way to get the store working please? All I get is a message saying I need to repair or reinstall it.
 


qavorq

Honorable Member
#2
As an addition to the above - I have now also lost the icon from my screen. The spot where it should be is still there but it is blank. If I click on the blank space it reacts as if the icon is still present.
 


#3
Did you upgrade from the ISO or Windows Update???
 


qavorq

Honorable Member
#4
Update from Win 7. Funny thing is though - I still have a copy of the last tech preview installed and I can access the store ok from there
 


#5
It could be a conflict with your build. I installed via the ISO (you can also upgrade via the ISO, it doesn't have to be a clean install) and the store works fine. Apparently a few people are having issues when upgrading.
 


qavorq

Honorable Member
#6
Thanks tetruss. . I think I shall have to go get a new dvd drive first then roll back and use the ios. Thanks for the info.
 


qavorq

Honorable Member
#7
Still no progress with this.
When I input the following into cmd using admin:
PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"

I get the following as a response:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could
not be registered.
error 0x80070002: While processing the request, the system failed to register
the windows.MRT extension due to the following error: The system cannot find
the file specified.
.
NOTE: For additional information, look for [ActivityId]
072b5501-cb61-0004-7963-2b0761cbd001 in the Event Log or use the command line
Get-AppxLog -ActivityID 072b5501-cb61-0004-7963-2b0761cbd001
At line:1 char:97
+ ... fest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manife ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : WriteError: (C:\Program File...ppxManifest.xml:S
tring) [Add-AppxPackage], IOException
+ FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa
nager.Commands.AddAppxPackageCommand

Anyone able to help please?
 


qavorq

Honorable Member
#8
Finally solved. Instead of running this command in cmd as admin:

PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"

I ran the following in a powershell as admin and this has solved the problem for me.

Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.