[SOLVED]Opening Text File Opens Command Prompt Instead

hawkeye62

Honorable Member
#1
Hi all:

I have the strangest problem. If I double click a .txt file, it opens a Command Prompt window rather than the .txt file! If I use right click, open with, choose default program, the check box for "Always use the selected program to open this kind of file" is grayed out. If I select Notepad the file will open with no problems, but there is no way to set Notepad as the default program. No where in file properties is there any mention of the cmd.exe program.

If I change the file extension to .rtf or .doc, it opens the file with no problems.

Any help will be appreciated.

Thanks, Jim
 


Trouble

Noob Whisperer
#2
Control Panel\All Control Panel Items\Default Programs\Set Associations (Associate a file type or protocol with a program)
Scroll all the way down to .txt and see what it says.
If it's anything other than notepad, click the change program button
 


hawkeye62

Honorable Member
#3
Thanks for your reply! Well, I got it to work with a slight difference from your method. Your method still would not change from Command Prompt to anything else. But, I went to the option to set default programs. I changed Wordpad to include .txt files as the default program. Then I closed Control panel and tried double click on a .txt file. It opened with Wordpad. Then I used your method to change Wordpad to Notepad and now it works properly.

Many thanks for pointing me in the right direction.

Jim
 


Trouble

Noob Whisperer
#4
Glad to hear that you managed to work it out and thanks for posting back and updating your thread with that information.
It will likely prove helpful to others.
Regards
Randy
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top