SP1 won't install sqmapi.dll missing

#1
I have a Dell 1525 laptop and the other day I was updating it with Windows updates. My laptop didn't have SP1 yet so I installed that with some other updates and then my internet stopped working, even though it showed as connected. So I did a system restore to before the updates which fixed the internet. Then I installed all the updates except SP1 and the internet still worked. But when I tried to install SP1 (either in win update or with SP1 download) I get the error, "missing sqmapi.dll".

This has happened to me before on a PC where I installed SP1 then did a system restore to uninstall it, then tried to install SP1 again, then got a similar error. So both times when uninstalling SP1 with system restore and trying to re-update SP1 has had the same consequences.

So what is going on?
 


#2
Hello raiden,

Not sure what's going on with your lappy, I have the same Dell Inspiron1525 and didn't have an issue after installing SP1.

Could you install it again, then after installation reboot if necessary, then click "Start", then "Run", then copy/paste SFC /scannow in the box and click "OK".
If that doesn't work, you could try locating the .dll, most likely in C:/Windows/System32, copy the .dll and place it on a CD, install SP1, then re-install/re-register the .dll file.

Here's a thread which seems to be the same issue;
SQMAPI.dll missing while installing Windows 7 SP1 - Operating Systems

Hope this helps

Don
 


#3
OK, I tried all that but SP1 still won't install. I think I'll just format and reinstall windows fresh.

Thanks
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#4
Try the Service pack readyness tool before doing a reinstall.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.