System and Compressing Memory Problem...

Discussion in 'Windows 10 Help and Support' started by Jason Ua, Feb 15, 2016.

  1. Jason Ua

    Jason Ua New Member

    Joined:
    Feb 15, 2016
    Messages:
    3
    Likes Received:
    0
    I installed Windows 10 and there is a task called 'System and Compressing Memory' that makes my disk goes to 100% and makes my computer lag.. Please tell me why that happens...
    Thank you for your time
     
  2. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,416
    Likes Received:
    366
    What is your memory usage when this happens?
     
  3. Jason Ua

    Jason Ua New Member

    Joined:
    Feb 15, 2016
    Messages:
    3
    Likes Received:
    0
    Around 40
     
  4. Jason Ua

    Jason Ua New Member

    Joined:
    Feb 15, 2016
    Messages:
    3
    Likes Received:
    0
    I restarted my PC, so it does not happen any more... But I still have that process when I installed Windows 10 again???
     
  5. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    This is a normal process, and a feature that allows Memory Manager to compress infrequently accessed memory pages. You may want to run a memory test to be sure there are no faults in your RAM, also make sure you install all updates as I believe this process has had one update since it's introduction. I believe this compressed memory may be flushed to a disk store, so if your hard drive is slow for some reason it could affect the speed of this operation greatly.

    For those of you with Insider Hub installed, you can open the following link in Edge and it should open in the Hub:
    insiderhub://announcements/4ff2fa6c-cf48-4ee5-990b-437010db59af
     
  6. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,416
    Likes Received:
    366
    This process is part of the kernel and is required. I believe it is responsible for moving data in and out of memory to the pagefile and hibernation file. Try disabling both features.

    For hibernation
    • Open an elevated command prompt and type powercfg /h off
    For system pagefile
    • Press (Windows Key + x)
    • Click on System
    • Click on Advanced System Settings
    • Under Performance click the settings button
    • Click on the advanced tab
    • Under "Virtual Memory" click Change
    • Uncheck Automatically Manage..."
    • Click the "No Page File" radio button and click Set
    • Reboot
     

Share This Page

Loading...