The diagnostics policy service is not running

#1
Whenever I try troubleshooting internet connection problems (which I often do) I run into the same message time and time again without fail; "The diagnostics policy service is not running" I attempted to go into services.msc and fix the problem, when I attempted to start the service manually I got the following message; "The Diagnostic Policy Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Please don't tell me to reformat my computer, because that's my last resort, I don't have any restore points from before the problem occurred, and I don't want to run a repair install. If anyone can find a solution I will be forever grateful.
 


Last edited:

Trouble

Noob Whisperer
#2
Have no idea what you may have tried up to this point, but assuming that you've checked the properties of the service and it's two related although not dependent services and none are set to disabled and two are using the local service account as a log on and the third is using the local system account as a log on. Then you may if you haven't already;
open device manager
expand network adapter
select each and all, right click and choose uninstall
when prompted if you would like to remove the drivers choose no
after everything is gone reboot, let the found new hardware wizard do it's thing and see if the service starts then.
Diagnostic Policy Service Start Up Type = Automatic Logon Tab set to Local Service
Diagnostic Service Host Start Up Type = Manual Logon Tab set to Local Service
Diagnostic System Host Start Up Type = Manual Logon Tab set to System Service
 


#3
I tried the network adaptor thing ages ago and it didn't help.
And it wont let me set the logon for Diagnostic System Host as anything other than Local Service
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.