.TXT files stuck on "System Information" as Current Default

Discussion in 'Windows 7 Help and Support' started by jonlane, Jun 25, 2010.

  1. jonlane

    jonlane New Member

    Joined:
    Jun 25, 2010
    Messages:
    10
    Likes Received:
    0
    [SOLVED].TXT files stuck on "System Information" as Current Default

    Hi

    I hope I can explain this properly!

    I have somehow changed the default programme for .txt files to open with so when I double click on a notepad file it says "This is not a file type System Information can open" befoe then opening a System Information window showing my pc configuration, ie not notepad!

    However if I right click on an existing .txt file and use "open with" Notepad then it is fine. And if I right click on my desktop and go to new text document it gives me a new one on my desktop, but if I double click on it I get the above problem.

    I have gone in to "Set Associations" to change the associated program to notepad but it doesnt change it. It still shows "name" as .txt, "Description" as TXT file and "Current Default" as System Information.

    Any thoughts would be appreciated?

    Thanks

    Jon
     
    #1 jonlane, Jun 25, 2010
    Last edited by a moderator: Jun 26, 2010
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    It's not clear from your description but when you select "open with" do you select notepad and also check the box to always use notepad?
     
  3. jonlane

    jonlane New Member

    Joined:
    Jun 25, 2010
    Messages:
    10
    Likes Received:
    0
    Hi Pat... if I right click on a txt file and go to "open with" and then "choose default program" it gives me 2 recommendations of Notepad and WordPad, but it does not let me put a tick in the "always use the selected program to open this kind of file"
     
  4. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Mr

    Have a look in the registry for this command:

    HKEY_CLASSES_ROOT\txtfile\shell\open\command

    It should have the entry:

    %SystemRoot%\system32\notepad.exe %1
     
  5. jonlane

    jonlane New Member

    Joined:
    Jun 25, 2010
    Messages:
    10
    Likes Received:
    0
    Re: Mr

    Mine says @%SystemRoot%\system32\notepad.exe,-469 which doesnt match what you say. I assume I should try changing it to what you say and see if that sorts it out. If not I can change it back.
     
  6. jonlane

    jonlane New Member

    Joined:
    Jun 25, 2010
    Messages:
    10
    Likes Received:
    0
    Re: Mr

    I tried that Pat and it didnt change anything.

    One thing I should have mentioned is that this started when I was trying to create an nfo file using a .txt file and somehow I must have changed the .txt files to open with System Information now.
     
  7. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Re: Mr

    There's a pile of file association fixes which I've used for some time - they were written for XP but it's worth trying for this problem provided you back up your registry first - download from here:

    Windows XP File Assocation Fixes
     
  8. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Re: Mr

    Open the atached zip and run the.reg. It will modify your registry back to the default.
     
  9. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Re: Mr

    Yes - that's the one from the website I suggested - but do backup the registry first please!
     
  10. jonlane

    jonlane New Member

    Joined:
    Jun 25, 2010
    Messages:
    10
    Likes Received:
    0
    Re: Mr

    Excellent... it worked!

    Thank you both for your help... you have saved me a weekend of frustration for such a little thing!
     
  11. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Re: Mr

    Glad it's sorted and thanks for the feedback.
     
  12. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Re: Mr

    Sorry Pat. I don't like horning in. I think I was probably typing my post when you planted this one. I didn't see it! But, FWIW, the original, now updated to Windows 7, is here.
    Maybe you, like myself, are always experimenting? I have copied all of those associate fixes into a folder of my computer. Handy to have around!

    File Association Fixes for Windows 7 - The Winhelponline Blog
     
    #12 RAK, Jun 25, 2010
    Last edited: Jun 26, 2010
  13. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Re: Mr

    No problem - and yes, like you, I've built a library of these useful bits and pieces over the years.
     

Share This Page

Loading...